Project

General

Profile

Bug #36463

Avatar?id=55038&size=50x50

Unable to communicate with iocage jail created with static ip

Added by Zackary Welch 11 months ago. Updated 7 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Lola Yang
Category:
Middleware
Target version:
Severity:
Medium
Reason for Closing:
Not Applicable
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When installing a plugin or creating a jail with a static ip, one becomes unable to connect to the jail after creation. During plugin install, the attached error occurs after about 20s, with the jail still being created despite the service not being installed. When a jail is created manually, pkg is unavailable with:

Bootstrapping pkg from pkg+http://pkg.FreeBSD.org/FreeBSD:11:amd64/quarterly, please wait...
pkg: Error fetching http://pkg.FreeBSD.org/FreeBSD:11:amd64/quarterly/Latest/pkg.txz: Non-recoverable resolver failure
A pre-built version of pkg could not be found for your system.
Consider changing PACKAGESITE or installing it from ports: 'ports-mgmt/pkg'.

It is important to note this only occurs with a static ip, and there are no problems with DHCP. Also, setting a subnet mask does not affect anything.
In addition, I have set a DNS in Network:Global Configuration and the console as 10.20.20.2, which works.
The full middleware traceback is attached as well.

plugininstall.png (43.5 KB) plugininstall.png Zackary Welch, 07/02/2018 11:36 AM
20128

Related issues

Related to FreeNAS - Feature #36483: Add fields to enter interface or netmask when installing a pluginClosed
Has duplicate FreeNAS - Bug #37253: Jail/Plugin cannot access to local LAN/Internet with fixed IPClosed
Is duplicate of FreeNAS - Bug #39533: Format Plugins IP address field in new UI to make it obvious that interface and mask are also requiredDone

History

#1 Updated by Dru Lavigne 11 months ago

  • Assignee changed from Release Council to William Grzybowski

#2 Updated by William Grzybowski 11 months ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-BETA2

Can you please investigate and help Zackary figure out whats wrong in the setup?

#3 Updated by Brandon Schneider 11 months ago

What is the command you use on the cli Zach? Or do you use the web UI?

#4 Avatar?id=55038&size=24x24 Updated by Zackary Welch 11 months ago

The plugin install and jail creation were tested in the new UI. The bootstrapping error I got running 'pkg install plexmediaserver' in a newly created jail with a static ip.

#5 Updated by Brandon Schneider 11 months ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Behaves as Intended
  • Needs Merging changed from Yes to No

Ok in that case, make sure you supply the host interface as well. Otherwise, it will not work. vtnet0|192.168.122.5 for example

#6 Updated by Dru Lavigne 11 months ago

  • Status changed from Closed to Unscreened
  • Assignee changed from Brandon Schneider to Erin Clark
  • Target version changed from 11.2-BETA2 to Backlog
  • Seen in changed from 11.2-BETA1 to Master - FreeNAS Nightlies
  • Reason for Closing deleted (Behaves as Intended)

Erin: let's discuss how to make this easier on the end-user as the whole point of Plugins is to provide a point and click install.

#7 Avatar?id=55038&size=24x24 Updated by Zackary Welch 11 months ago

  • Related to Feature #36483: Add fields to enter interface or netmask when installing a plugin added

#8 Updated by Erin Clark 11 months ago

  • Assignee changed from Erin Clark to Lola Yang

#9 Updated by William Grzybowski 10 months ago

  • Has duplicate Bug #37253: Jail/Plugin cannot access to local LAN/Internet with fixed IP added

#10 Updated by Dru Lavigne 7 months ago

  • Is duplicate of Bug #39533: Format Plugins IP address field in new UI to make it obvious that interface and mask are also required added

#11 Updated by Dru Lavigne 7 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Not Applicable

This issue was fixed on the duplicate ticket.

#12 Updated by Dru Lavigne 7 months ago

  • File deleted (traceback.txt)

#13 Updated by Dru Lavigne 7 months ago

  • File deleted (debug.tgz)

Also available in: Atom PDF