Project

General

Profile

Feature #36483

Avatar?id=55038&size=50x50

Add fields to enter interface or netmask when installing a plugin

Added by Zackary Welch about 1 year ago. Updated 10 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Warren Block
Category:
GUI (new)
Target version:
Estimated time:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Currently the plugin installation form includes only 3 fields, DHCP, ipv4 address, and ipv6 address. If one wants to select an interface, it has to be done with interface|ipaddress/netmask. However, the tool tip and even the docs for plugins does not mention this as a possibility. The docs should either include this as part of the tool tip/section 12 or there should be fields for netmask and interface.


Related issues

Related to FreeNAS - Bug #36463: Unable to communicate with iocage jail created with static ipClosed
Is duplicate of FreeNAS - Bug #39533: Format Plugins IP address field in new UI to make it obvious that interface and mask are also requiredDone

History

#1 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

  • Subject changed from Add an option to select interface when installing a plugin to Add fields to enter interface or netmask when installing a plugin

#2 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to Warren Block
  • Target version changed from Backlog to 11.2-RC2

#4 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

For further clarification, this is when installing a plugin. Currently there is only one field for IPv4 address, so if you need to use an interface or netmask you have to use iocage syntax. I talked to Brandon and William about this and they said the UI should probably have separate options or an explanation of the iocage syntax.

#5 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

  • Related to Bug #36463: Unable to communicate with iocage jail created with static ip added

#6 Avatar?id=13649&size=24x24 Updated by Ben Gadd about 1 year ago

  • Target version changed from 11.2-RC2 to Backlog

#8 Updated by Dru Lavigne 10 months ago

  • Is duplicate of Bug #39533: Format Plugins IP address field in new UI to make it obvious that interface and mask are also required added

#9 Updated by Dru Lavigne 10 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF