Project

General

Profile

Bug #36583

Avatar?id=55038&size=50x50

Close dialog when zpool is detached

Added by Zackary Welch almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
GUI (new)
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I'm unsure if this is necessarily a bug or a feature, but it seems the current behaviour is unintended. When one goes to detach a pool, the dialog does not close after detachment, instead after the "Please wait" dialog finishes, the first dialog to confirm detachment still persists and the user must click "Cancel". Considering the only options are the two checkboxes, "Detach" and "Cancel," it seems unnecessary to keep the dialog open. I doubt the user is going to detach the now detached pool.


Related issues

Is duplicate of FreeNAS - Bug #35323: Fix detach pool dialog remaining open after pool is detached in new UIDone

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Is duplicate of Bug #35323: Fix detach pool dialog remaining open after pool is detached in new UI added

#2 Updated by Dru Lavigne almost 3 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-BETA2 to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF