Project

General

Profile

Bug #36653

Add warning to configure the interface used by the UI

Added by Timothy Moore II 10 months ago. Updated 9 months ago.

Status:
Done
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I've been testing bugs with the Network/Interfaces section of the new UI. I discovered the WebUI interface must be manually added to this screen before adding any other interface, otherwise all ability to connect to the WebUI is lost. The only fix I have found for this is to reset the system configuration to defaults. Would it be possible to automatically add the Webui Interface to Network/Interfaces during or post install?


Related issues

Related to FreeNAS - Bug #37168: Implement interfaces.websocket_interface which returns the interface the websocket is connected toDone

Associated revisions

Revision 22694889 (diff)
Added by Erin Clark 10 months ago

Add warning to let the user know they should configure the webui interface first

Ticket: #36653

History

#1 Updated by Dru Lavigne 10 months ago

  • Tracker changed from Feature to Bug
  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-RC2
  • Seen in set to Master - FreeNAS Nightlies
  • ChangeLog Required set to No

Erin: this sounds more like a bug than a feature.

#2 Updated by Erin Clark 10 months ago

  • Status changed from Unscreened to Screened

#3 Updated by Erin Clark 10 months ago

I confirmed with William that this has always been a problem and he plans to do something to fix it in either 11.3 or later. For now I could add a warning that pops up when the user tries to create their first interface to let them know that the first interface they make should be the one they use to configure FreeNAS with.

#4 Updated by Erin Clark 10 months ago

  • Status changed from Screened to In Progress
  • Assignee changed from Erin Clark to Vaibhav Chauhan

#5 Updated by Dru Lavigne 10 months ago

  • Target version changed from 11.2-RC2 to 11.2-BETA2

#6 Updated by Vaibhav Chauhan 9 months ago

  • Assignee changed from Vaibhav Chauhan to Erin Clark

reviewed but not merged

#7 Updated by Warren Block 9 months ago

Erin Clark wrote:

I confirmed with William that this has always been a problem and he plans to do something to fix it in either 11.3 or later. For now I could add a warning that pops up when the user tries to create their first interface to let them know that the first interface they make should be the one they use to configure FreeNAS with.

That would be an improvement, but is really something the system should do for that user, rather than just telling them. There is a problem with the current network interface paradigm in that the user can't see network interfaces unless they "add" them. Really, the "add" means "override the default settings on this interface". This is confusing to the user, since the physical interfaces are already present.

We should improve this. Rather than having an invisible default interface, we should just list all the interfaces present and their current configuration. If the user wants to edit one, let them do it, but don't put them in the situation of not being able to see what is going on or tell them to add interfaces that are already there.

#8 Updated by Erin Clark 9 months ago

I agree but that isn't how the middleware handles it yet, the UI is merely reflecting the way the backend handles the interfaces (and hence how the old UI does it too currently)

#9 Updated by Erin Clark 9 months ago

warning has been merged but I will also look for ways to tell the user which interface is the one they should configure

#10 Updated by Erin Clark 9 months ago

  • Related to Bug #37168: Implement interfaces.websocket_interface which returns the interface the websocket is connected to added

#11 Updated by Erin Clark 9 months ago

There is not currently a reliable way to tell what interface the user should configure so I have created a ticket for a middleware call for this: https://redmine.ixsystems.com/issues/37168

#12 Updated by Dru Lavigne 9 months ago

  • Subject changed from Improve usability of Network/Interfaces to Add warning to configure the interface used by the UI
  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#13 Updated by Timothy Moore II 9 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Testing with FreeNAS System updated to FreeNAS-11.2-MASTER-201807160837:

Go to Network/Interfaces. Click “Add”. Warning popup appears with confirmation checkbox.

#14 Updated by Dru Lavigne 9 months ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

Also available in: Atom PDF