Project

General

Profile

Bug #36728

Fix for ISO upgrade in BIOS and UEFI mode

Added by Michael Reynolds about 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I attempted to upgrade an 11.1U5 FreeNAS install to the FreeNAS-INTERNAL14 by booting the INTERNAL14 ISO

The installation errored out with the error
The FreeNAS upgrade on ada0 has failed. Press enter to continue..

See 11.1U5-upgradeINTERNAL14-Fail-2018-07-05.png

I got the error using a VirtualBox install
Bonnie was able to reproduce using a real ISO on a mini
Bonnie currently has the error up on the mini with her failed attempt.

11.1U5-upgradeINTERNAL14-Fail-2018-07-05.png (54.8 KB) 11.1U5-upgradeINTERNAL14-Fail-2018-07-05.png Michael Reynolds, 07/05/2018 12:58 PM
Screen Shot 2018-07-05 at 4.52.06 PM.png (115 KB) Screen Shot 2018-07-05 at 4.52.06 PM.png Bonnie Follweiler, 07/05/2018 02:00 PM
BE-Created-2018-07-05.png (2.64 KB) BE-Created-2018-07-05.png Michael Reynolds, 07/05/2018 02:49 PM
BE-available-after-failed-2018-07-05.png (12 KB) BE-available-after-failed-2018-07-05.png Michael Reynolds, 07/05/2018 02:49 PM
Grub-BE-Menu-2018-07-05.png (5.45 KB) Grub-BE-Menu-2018-07-05.png Michael Reynolds, 07/05/2018 02:49 PM
GrubMenu-2018-07-05.png (5.53 KB) GrubMenu-2018-07-05.png Michael Reynolds, 07/05/2018 02:49 PM
Progress1-2018-07-05.png (5.36 KB) Progress1-2018-07-05.png Michael Reynolds, 07/05/2018 02:49 PM
Progress2-2018-07-05.png (54.8 KB) Progress2-2018-07-05.png Michael Reynolds, 07/05/2018 02:49 PM
console-accessing the gui.jpeg (189 KB) console-accessing the gui.jpeg Bonnie Follweiler, 07/06/2018 06:59 AM
Internal16 - 5.jpg (2.79 MB) Internal16 - 5.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 - 3.jpg (2.46 MB) Internal16 - 3.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 - 6.jpg (2.96 MB) Internal16 - 6.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 - 7.jpg (2.37 MB) Internal16 - 7.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 - 9.jpg (2.41 MB) Internal16 - 9.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 10.jpg (2.47 MB) Internal16 10.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 12.jpg (2.57 MB) Internal16 12.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 11.jpg (2.48 MB) Internal16 11.jpg Bonnie Follweiler, 07/06/2018 07:21 AM
Internal16 13.jpg (2.58 MB) Internal16 13.jpg Bonnie Follweiler, 07/06/2018 07:23 AM
Internal16 15.jpg (2.55 MB) Internal16 15.jpg Bonnie Follweiler, 07/06/2018 07:23 AM
Internal16 19.jpg (2.54 MB) Internal16 19.jpg Bonnie Follweiler, 07/06/2018 07:23 AM
Internal16 18.jpg (2.47 MB) Internal16 18.jpg Bonnie Follweiler, 07/06/2018 07:23 AM
Internal16 21.jpg (2.48 MB) Internal16 21.jpg Bonnie Follweiler, 07/06/2018 07:23 AM
Internal16 22.jpg (2.42 MB) Internal16 22.jpg Bonnie Follweiler, 07/06/2018 07:23 AM
Internal16 23.jpg (2.4 MB) Internal16 23.jpg Bonnie Follweiler, 07/06/2018 07:23 AM
20353
20368
20373
20378
20383
20388
20393
20398
20483
20513
20518
20523
20528
20533
20538
20543
20548
20553
20558
20563
20568
20573
20578
20583

Associated revisions

Revision cf9882f7 (diff)
Added by Alexander Motin about 2 years ago

Don't give `set +e` chance to fire without real reason. Ticket: #36728

Revision c8ef8260 (diff)
Added by Alexander Motin about 2 years ago

Don't give `set +e` chance to fire without real reason. (#1491) Ticket: #36728

History

#1 Updated by Michael Reynolds about 2 years ago

Upgrading 11.1U5 to 11.2INTERNAL14 is a failure when upgrading into a new be

Upgrading and wiping the boot drive is successful

#2 Updated by Bonnie Follweiler about 2 years ago

  • File FreeNAS_Upgrade.jpg added

#3 Updated by Bonnie Follweiler about 2 years ago

  • File deleted (FreeNAS_Upgrade.jpg)

#5 Updated by Bonnie Follweiler about 2 years ago

20368

The FreeNAS 11.2-Internal14 installer did create an entry in the GUI System->Boot's BE list and it is marked to run at reboot but it will not boot/reboot into that BE

#6 Updated by Bonnie Follweiler about 2 years ago

Please note that the manual update works for FreeNAS 11.2-INTERNAL14

#7 Updated by Bonnie Follweiler about 2 years ago

  • Assignee changed from William Grzybowski to Alexander Motin

#8 Updated by Michael Reynolds about 2 years ago

20373
20378
20383
20388
20393
20398

Cloned a FreeNAS 11.1U5 install
Booted the VM and enabled SSH login
Rebooted to the 11.2INTERNAL14 ISO
Install/Upgrade
Chose ada0
Upgrade Install
Install in new boot environment
It looks like the BE is created successfully
BE-Created-2018-07-05.png
Grabbed a screenshot before the install finished
Progress1-2018-07-05.png
Errored out with same error as before
Progress2-2018-07-05.png
Cannot ssh in

"powered off" the VM via File -> Close
Started the VM and checked the available boot environments
see BE-available-after-failed-2018-07-05.png
default is active Now
default-20180705-204444 is the On Reboot

Reboot to see if the 11.2INTERNAL14 install loads
The GRUB menu shows the default be from 2018-05-23 to be the default
See GrubMenu-2018-07-05.png

Chose the Boot Environment Menu
The be for the upgrade does not show up in the list
See Grub-BE-Menu-2018-07-05.png

Booted the old default be
The be list is the same as before and still shows default-20180705-204444
as the BE that will be active on Reboot.

Last reboot I used option 10 on the FreeNAS Console setup menu
Rebooted using the UI
No change from above

ssh'd in. beadm list agrees with the UI about the boot environments available
root@freenas:~ # beadm list
BE Active Mountpoint Space Created Nickname
default N / 838.9M 2018-05-23 17:53 default
Initial-Install - - 1.9M 2018-05-23 17:59 Initial-Install
Wizard-2018-05-23_15:05:14 - - 558.0K 2018-05-23 18:05 Wizard-2018-05-23_15:05:14
default-20180705-204444 R - 876.0M 2018-07-05 16:44 default-20180705-204444

#9 Updated by Bonnie Follweiler about 2 years ago

20483

Update: I tried to update, from an iso on a brand new 32GB USB stick, from FreeNAS 11.1-U5 to FreeNAS 11.2-Internal16 and It appeared to install until I got "The FreeNAS upgrade on ada2 has failed. Press enter to continue"
I press enter and get the FreeNAS 11.2-INTERNAL16 Console Setup screen with Install/Upgrade highlighted
I chose to reboot (removing the USB drive)
It is trying to mount root from the update freenas-boot/root/default-20180706-133317 []
It tried to boot and the new UI. it wont load
I tried the legacy UI and got the following traceback error:

Request Method: GET
Request URL: http://10.231.3.50/legacy/
Software Version: FreeNAS-11.2-INTERNAL16 (529027503)
Exception Type: FileNotFoundError
Exception Value:

[Errno 2] No such file or directory

Exception Location: /usr/local/lib/python3.6/site-packages/ws4py/client/__init__.py in connect, line 208
Server time: Fri, 6 Jul 2018 09:51:44 -0400

Traceback

Environment:

Software Version: FreeNAS-11.2-INTERNAL16 (529027503)
Request Method: GET
Request URL: http://10.231.3.50/legacy/

Traceback:
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/exception.py" in inner
42. response = get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in legacy_get_response
249. response = self._get_response(request)
File "/usr/local/lib/python3.6/site-packages/django/core/handlers/base.py" in _get_response
178. response = middleware_method(request, callback, callback_args, callback_kwargs)
File "./freenasUI/freeadmin/middleware.py" in process_view
163. return login_required(view_func)(request, *view_args, **view_kwargs)
File "/usr/local/lib/python3.6/site-packages/django/contrib/auth/decorators.py" in _wrapped_view
23. return view_func(request, *args, **kwargs)
File "/usr/local/lib/python3.6/site-packages/django/views/decorators/cache.py" in _wrapped_view_func
57. response = view_func(request, *args, **kwargs)
File "./freenasUI/freeadmin/site.py" in adminInterface
236. 'menu_hook': appPool.get_top_menu(request),
File "./freenasUI/freeadmin/apppool.py" in get_top_menu
45. arr = self._get_array("top_menu", None, request)
File "./freenasUI/freeadmin/apppool.py" in _get_array
35. method(arr, func(*args, **kwargs))
File "./freenasUI/vcp/hook.py" in top_menu
38. if vcp_enabled():
File "./freenasUI/vcp/utils.py" in vcp_enabled
33. with client as c:
File "./freenasUI/middleware/client.py" in enter
20. local.client = Client()
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in init
313. raise e
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in init
306. self._ws.connect()
File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py" in connect
169. rv = super(WSClient, self).connect()
File "/usr/local/lib/python3.6/site-packages/ws4py/client/
_init__.py" in connect
208. self.sock.connect(self.bind_addr)

Exception Type: FileNotFoundError at /legacy/
Exception Value: [Errno 2] No such file or directory

Request information
GET

No GET data
POST

No POST data
FILES

No FILES data
COOKIES
Variable Value
csrftoken '********'
fntreeSaveStateCookie 'root'
sessionid '2bse2pawad1lbg0tejmra7zp7y2o6gav'
META
Variable Value

After attempting to access the GUI there was also a lot of error messages on my console - screenshot provided

#10 Updated by Bonnie Follweiler about 2 years ago

20513
20518
20523
20528
20533
20538
20543
20548

I apologize, in advance for the number of photos but these are the messages on the console during the install:

#11 Updated by Bonnie Follweiler about 2 years ago

  • File deleted (Internal16 - 2.jpg)

#12 Updated by Bonnie Follweiler about 2 years ago

  • File deleted (Internal16 - 1.jpg)

#14 Updated by Alexander Motin about 2 years ago

  • Category changed from Middleware to OS
  • Status changed from Unscreened to Ready for Testing
  • Target version changed from Backlog to 11.2-BETA2
  • Severity changed from New to High

#15 Updated by Dru Lavigne about 2 years ago

  • Target version changed from 11.2-BETA2 to 11.2-BETA1

#16 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Failed upgrade 11.1U5 to INTERNAL14 or 16 using the ISO to Fix for EFI upgrade
  • Needs Doc changed from Yes to No

#17 Updated by Dru Lavigne about 2 years ago

  • Needs Merging changed from Yes to No

#18 Updated by Alexander Motin about 2 years ago

  • Subject changed from Fix for EFI upgrade to Fix for ISO upgrade in BIOS mode

#21 Updated by Alexander Motin about 2 years ago

Make sure to test both UEFI and BIOS cases.

#22 Updated by Michael Reynolds about 2 years ago

Used the INTERNAL17 ISO to upgrade 11.1U5 to a new be
the initial upgrade was butter
rebooted to finish the upgrade and make sure everything boots
the initial reboot finished updating/converting everything to the current version
rebooted again and everything booted fine

This test was done using BIOS

I don't have access to test using UEFI

#23 Updated by Michael Reynolds about 2 years ago

  • Subject changed from Fix for ISO upgrade in BIOS mode to Fix for ISO upgrade in BIOS and UEFI mode
  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Spoke with Bonnie
Tested upgrading on a UEFI boot based system and testing passed

BIOS and UEFI testing passed

#24 Updated by Bonnie Follweiler about 2 years ago

I did a clean install UEFI Boot and it was successful

#25 Updated by Alexander Motin about 2 years ago

Bonnie Follweiler wrote:

I did a clean install UEFI Boot and it was successful

Interesting question is updating after that.

#26 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF