Project

General

Profile

Bug #36823

Fix unneeded stops and restarts in AD monitoring

Added by Andrew Walker about 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
John Hixson
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When I execute "midclt call servicemonitor.stop", self.finished.set() is , which makes "self.finished.wait(self.frequency)" non-blocking; however, we don't stop the servicemonitor thread while "connected and started and enabled" are true.

This causes AD monitoring to go nuts and perform checks as quickly as possible, which in some environments causes the checks to fail and the AD service to either stop or restart. The latter option (restarting) usually succeeds, but causes a service interruption. Since the service monitor thread is still running, it will repeatedly restart causing fairly regular service disruptions.

Part of larger set of fixes to AD monitoring. PR#1340


Related issues

Related to FreeNAS - Bug #33453: Fix unnecessary AD restarts caused by enabling service monitorDone
Has duplicate FreeNAS - Bug #35943: AD service restartsClosed

History

#1 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to John Hixson

#2 Updated by John Hixson about 2 years ago

  • Status changed from Unscreened to Ready for Testing
  • Target version changed from Backlog to 11.2-RC2

#3 Updated by Dru Lavigne about 2 years ago

  • Subject changed from stop method for service monitor doesn't work to Fix unneeded stops and restarts in AD monitoring
  • Target version changed from 11.2-RC2 to 11.2-BETA2
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#4 Updated by Dru Lavigne about 2 years ago

  • Has duplicate Bug #35943: AD service restarts added

#6 Updated by Dru Lavigne about 2 years ago

  • Status changed from Ready for Testing to Done

#8 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #33453: Fix unnecessary AD restarts caused by enabling service monitor added

Also available in: Atom PDF