Project

General

Profile

Bug #37268

Shorten page titles displayed in tabs of new UI

Added by Michael Dexter about 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

With multiple truncated tabs, the FreeNAS window title might be "Session > Signin | Fr..."
Consider simply the host name such as "freenas.local" as "Session" does not imply a relationship to FreeNAS.

"Material UI" is also meaningless to this user.

See attached image.

WindowTitle.jpg (2.81 KB) WindowTitle.jpg Michael Dexter, 07/10/2018 01:54 AM
Screenshot from 2018-07-19 09-37-53.png (9.89 KB) Screenshot from 2018-07-19 09-37-53.png Dennis Mullen, 07/19/2018 06:41 AM
20783
21973

Associated revisions

Revision 00410d5e (diff)
Added by Dennis Mullen about 2 years ago

Shorten page titles displayed in tabs Ticket: #37268

History

#1 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Erin Clark

#2 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.2-BETA2

#4 Updated by Erin Clark about 2 years ago

As discussed in meeting, we think this should say "FreeNAS - <ip address or hostname>"

#5 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to Dennis Mullen

#7 Updated by Dennis Mullen about 2 years ago

  • Status changed from Unscreened to In Progress
  • Severity changed from New to Low

#8 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Consider shorter/more descriptive browser window title to Shorten page titles displayed in tabs of new UI
  • Needs Doc changed from Yes to No

#9 Updated by Erin Clark about 2 years ago

  • Status changed from In Progress to Ready for Testing

#10 Updated by Dru Lavigne about 2 years ago

  • Needs Merging changed from Yes to No

#11 Updated by Aaron St. John about 2 years ago

  • Status changed from Ready for Testing to Passed Testing

Tested on latest nightlies (FreeNAS-11.2-MASTER-201807200857)

This works as intended; even for dynamic IP addresses.

#12 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF