Project

General

Profile

Bug #37388

UEFI bsdloader fails on Lenovo ThinkServer TS140

Added by Philip Robar about 1 year ago. Updated 6 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Cannot Reproduce
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Lenovo ThinkServer TS140
Intel C226 server chipset (5 x SATA, Gb NIC, USB3)
BIOS: CZA 5/2018
Intel AMT 9 remote management
Intel Core i3-4330
16GB ECC memory (4x4GB, 32GB max)
LSI SAS3041E-R PCIe 4x SATA/SAS controller flashed to IT mode (no drives attached)
Vantec UGT-ST310R PCI SATA controller (No drives attached.)
3TB: 2x3TB mirror
2TB: 2x2TB mirror

ChangeLog Required:
No
Tags:

Description

I tried updating from 11.1u5 to 11.2-beta1 and it failed. I don't even get a boot menu (It appears to go directly to loading the OS.) so I can't roll back.

IMG_20180710_131944149.jpg (1.14 MB) IMG_20180710_131944149.jpg Philip Robar, 07/10/2018 10:36 AM
FreeNas bootloader fail.jpg (1.21 MB) FreeNas bootloader fail.jpg Philip Robar, 12/15/2018 10:32 AM
20838
45357

History

#1 Updated by Philip Robar about 1 year ago

Also, one of my pools is missing from the "ZFS found the following pools:" line.

#2 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to Alexander Motin

#3 Updated by Alexander Motin about 1 year ago

Could you try to disconnect all extra disks and controllers not required to boot to see whether it change anything?

#4 Updated by Alexander Motin about 1 year ago

Could you also try to remove all media, insert some other boot device and try fresh BETA1 install in both UEFI and BIOS mode? Unfortunately we are so low on information there, that any bit may count.

#5 Updated by Philip Robar about 1 year ago

I pulled each add-in controller, one at a time, then I unhooked all the drives except for the two boot flash drives. It didn't help.

#6 Updated by Alexander Motin about 1 year ago

It seems like some issue between new bsdloader used in BETA1 instead of GRUB and your system, may be UEFI BIOS. Could you check for newer BIOS availability for the system?

#7 Updated by Alexander Motin about 1 year ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Unfortunately not sure we can reproduce this issue without having the specific hardware. We will continue polishing the loader before 11.2 release. Until that as workaround you could try to reinstall it in legacy BIOS mode to see whether that help. As a way to return back to 11.1 ISO reinstall into new dataset may do the trick, but not sure we tested that path much yet. We will.

#8 Updated by Philip Robar about 1 year ago

Turns out my BIOS was quite old. I updated to the latest version, CZA 5/2018, but it didn't help. I tried both UEFI and compatibility mode with legacy boot as the first try.

I'm going to download the beta and the latest nightly to see if either will work as an upgrade or fresh install.

#9 Updated by Philip Robar about 1 year ago

  • Hardware Configuration updated (diff)

#10 Updated by Philip Robar about 1 year ago

Both the 11.2-beta1 and FreeNAS-11.2-MASTER-201807110935-c26be3b nightly installers boot and run as expected, but either installing into a new boot environment or installing fresh results in the same hang, both in UEFI and legacy boot modes.

#11 Updated by Philip Robar about 1 year ago

Trying to recover via an upgrade install of 11.1u5 into a new boot environment did't work, but I was able to recover by doing an upgrade install with the Format option. The upgrade process successfully preserved my configuration and my Plex jail.

#12 Updated by Philip Robar about 1 year ago

Spoke too soon. Lots of things aren't working including the Alert button, the sharing / Windows (SMB) tab, and control services. Sigh, looks like I get to reinstall and set up everything from scratch. I guess I was right to be concerned about the unexpected verbosity of scripts during the initial boot and migration process that I saw.

#13 Updated by Alexander Motin about 1 year ago

That is probably because your database was already upgraded to 11.2 version on first boot before loader was replaced to on that is unable to boot on your hardware. :(

#14 Updated by Alexander Motin about 1 year ago

  • Subject changed from Upgrade from 11.1u5 to 11.2-beta1 failed to bsdloader fails on Lenovo ThinkServer TS140

#15 Updated by Alexander Motin about 1 year ago

  • Severity changed from New to Medium

#16 Updated by Alexander Motin 12 months ago

  • Assignee changed from Alexander Motin to Ryan Moeller

#17 Updated by Dru Lavigne 9 months ago

Phillip: is this still an issue for you or should we close out this ticket?

#18 Updated by Philip Robar 9 months ago

I won't be able to test the RC1 release until about a week from now. I'd appreciate it you left this open till then.

#19 Updated by Ryan Moeller 8 months ago

  • Reason for Blocked changed from Need additional information from Author to Waiting for feedback

#20 Updated by Philip Robar 8 months ago

The upgrade to 11.2 worked as expected. My server rebooted twice, both times it used GRUB.

#21 Updated by Dru Lavigne 8 months ago

Are you able to access the UI on the booted system? If so, please attach a debug (System -> Advanced -> Save debug) to this ticket.

#22 Updated by Philip Robar 8 months ago

  • File debug-server-20181207125743.tgz added

From what I can tell from the FreeBSD documentation my /boot looks like it has the FreeBSD boot stuff in it, but the boot choice screen that I saw during the two reboots definitely said GRUB 2 something. I've attached a debug capture as requested.

#23 Updated by Dru Lavigne 8 months ago

  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Waiting for feedback)

#24 Updated by Philip Robar 7 months ago

45357

I knew it was too good to be true. I rebooted trying to get the broken Plex plugin to work and of course my server failed to boot. And also of course I foolishly updated my pools so now I can't go back to 11.1 and I'm really screwed.

#25 Updated by Ryan Moeller 7 months ago

  • Status changed from Unscreened to Not Started

Philip, this is a long shot, but do you have an option in UEFI that looks related to PXE or a UEFI network stack or something like that? If so, please try turning it off. I have seen bsdloader get hung up in initialization of UEFI network drivers.

#26 Updated by Philip Robar 7 months ago

I'll take a look for any network booting options, but in the meantime:

I got it to work. After trying various forms of UEFI booting:

A) Legacy BIOS boot support on, UEFI boot.

1) Upgrade install into new boot env w/o reformatting.
2) Upgrade install with reformatting.

B) Legacy BIOS boot support off, UEFI boot.

1) Fresh install with reformatting.
2) Fresh install to a different USB flash drive.

None of which worked. The only thing that worked was installing with the BIOS boot option and legacy boot support on in the BIOS.

Oddly enough the installation image boots just fine in UEFI mode.

#27 Updated by Ryan Moeller 6 months ago

  • Subject changed from bsdloader fails on Lenovo ThinkServer TS140 to UEFI bsdloader fails on Lenovo ThinkServer TS140
  • Status changed from Not Started to Blocked

Philip are you able to check that setting? If not, can I close this ticket since you got it working in BIOS mode?

#28 Updated by Ryan Moeller 6 months ago

  • Reason for Blocked set to Need additional information from Author

#29 Updated by Ryan Moeller 6 months ago

  • Status changed from Blocked to Closed
  • Reason for Closing set to Cannot Reproduce
  • Reason for Blocked deleted (Need additional information from Author)

Closing this as there has been no response for a few weeks after the workaround was found.

Philip: Please add a note here if you do get a chance to test disabling the PXE setting. Thanks!

#30 Updated by Dru Lavigne 6 months ago

  • File deleted (debug-server-20181207125743.tgz)

#31 Updated by Dru Lavigne 6 months ago

  • Target version changed from Backlog to N/A

Also available in: Atom PDF