Project

General

Profile

Bug #37666

Avatar?id=55038&size=50x50

Remove ellipsis on overflow to allow data to show in new UI

Added by Zackary Welch about 1 year ago. Updated 12 months ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When listing cloud sync tasks, the table is too long to view without a horizontal slider. If the slider is completely to the left, the table is greyed out. Otherwise the table display fine.

nogrey.png (16 KB) nogrey.png Zackary Welch, 07/11/2018 09:30 AM
greyed.png (7.88 KB) greyed.png Zackary Welch, 07/11/2018 09:30 AM
21010
21014

Related issues

Related to FreeNAS - Bug #37453: Checkboxes move when clickedClosed
Related to FreeNAS - Bug #37854: NTP Servers list disappearsClosed
Has duplicate FreeNAS - Bug #37566: Tasks/Cron Jobs table doesn't display information when the horizontal scrollbar is fully to the leftClosed

History

#1 Avatar?id=55038&size=24x24 Updated by Zackary Welch about 1 year ago

I don't see why the table should be the wide anyway, since Enabled will only be "yes" or "no" but the cell is very wide.

#2 Updated by Dru Lavigne about 1 year ago

  • Target version changed from Backlog to 11.2-RC2

#3 Updated by Erin Clark about 1 year ago

  • Assignee changed from Erin Clark to Dennis Mullen

#4 Updated by Dennis Mullen about 1 year ago

  • Has duplicate Bug #37566: Tasks/Cron Jobs table doesn't display information when the horizontal scrollbar is fully to the left added

#5 Updated by Dennis Mullen about 1 year ago

  • Status changed from Unscreened to Screened

This issue affects all entity tables, and appears on Firefox on TrueOS. I don't see it in Chromium on TrueOS or in either browser on Linux.

It is caused by the browser's interpretation of the 'text-overflow: ellipsis' style which is applied to each table.

Removing this style is mostly harmless as long as we are using the new horizontal scroll bar. One thing to not: When you load up one of the three big tables with column-select check-boxes, then toggle to select all, columns will be jammed together until you move the scroll bar, and then will spread out to normal width. But with the ellipsis style, this happens anyway, and is harder to read besides.

#6 Updated by Dennis Mullen about 1 year ago

  • Related to Bug #37453: Checkboxes move when clicked added

#7 Updated by Dennis Mullen about 1 year ago

PR 986
This is a different issue from #37453, but it has the same solution.

#8 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Graphical glitch with Cloud Sync Task table to Remove ellipsis on overflow to allow data to show in new UI
  • Status changed from Screened to Ready for Testing
  • Target version changed from 11.2-RC2 to 11.2-BETA2
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#9 Updated by Bonnie Follweiler 12 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Passed Testing in FreeNAS-11.2-MASTER-201807160837
(Build Date: Jul 16, 2018 11:40)

Test Case: In the Cloud Sync Task slide the horizontal slider to the left to make sure it doesn't grey it out

#10 Updated by Dru Lavigne 12 months ago

  • Status changed from Passed Testing to Done

#11 Updated by Dru Lavigne 11 months ago

  • Related to Bug #37854: NTP Servers list disappears added

Also available in: Atom PDF