Project

General

Profile

Bug #37706

Fix bad caching on list_resource in Jails Wizard in new UI

Added by Timothy Moore II 9 months ago. Updated 9 months ago.

Status:
Done
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Testing with FreeNAS Mini manually updated to FreeNAS-11.2-MASTER-201807110935:

Went to Jails and opened the wizard to create a new jail. Entered a jail name, but could not select a FreeBSD "Release" from the drop-down menu. Switched to Advanced Jail Creation. The same behavior is visible. Previous behavior was to list all available FreeBSD releases that iocage could fetch and store. A user could choose a release and continue with the jail creation process.

jail-wizard-noreleases.png (55.2 KB) jail-wizard-noreleases.png Timothy Moore II, 07/11/2018 10:32 AM
21082

Related issues

Related to FreeNAS - Bug #37774: something wrong with resolv.confClosed
Has duplicate FreeNAS - Bug #37702: No release options when creating a jailClosed
Blocks FreeNAS - Bug #35062: Stop iocage jails before locking drive that contains jailsDone

Associated revisions

Revision 919c5e4e (diff)
Added by Brandon Schneider 9 months ago

fix(plugins/jail): Bad caching on list_resource

This caused a remote cache to be consumed by a local cache. They are now distinct.

Ticket: #37706

Revision e82eeff7 (diff)
Added by Brandon Schneider 9 months ago

fix(plugins/jail): Bad caching on list_resource (#1535)

  • fix(plugins/jail): Bad caching on list_resource

This caused a remote cache to be consumed by a local cache. They are now distinct.

Ticket: #37706

  • Address William's review

History

#1 Updated by Erin Clark 9 months ago

  • Assignee changed from Erin Clark to Lola Yang

#2 Updated by Dru Lavigne 9 months ago

  • Target version changed from Backlog to 11.2-BETA2

#3 Updated by Lola Yang 9 months ago

  • Status changed from Unscreened to Screened

#4 Updated by Lola Yang 9 months ago

  • Status changed from Screened to In Progress
  • Assignee changed from Lola Yang to Erin Clark

The problem is caused by DNS or your server is blocked. Indeed ui need to show the error message, I created a PR to add error handler for jail add and jail wizard https://github.com/freenas/webui/pull/985

#5 Updated by Lola Yang 9 months ago

  • Related to Bug #37774: something wrong with resolv.conf added

#6 Updated by Lola Yang 9 months ago

Lola Yang wrote:

The problem is caused by DNS or your server is blocked. Indeed ui need to show the error message, I created a PR to add error handler for jail add and jail wizard https://github.com/freenas/webui/pull/985

I asked Brandon about this ticket, he find out the problem is caused by a bad entry from resolv.conf (for my server). I opened a ticket for it.

#7 Updated by Lola Yang 9 months ago

  • Has duplicate Bug #37702: No release options when creating a jail added

#8 Updated by Dru Lavigne 9 months ago

  • Blocks Bug #35062: Stop iocage jails before locking drive that contains jails added

#9 Updated by Brandon Schneider 9 months ago

#10 Updated by Eric Turgeon 9 months ago

  • Status changed from In Progress to Passed Testing
  • Needs QA changed from Yes to No
  • Needs Merging changed from Yes to No

It have fixed the automation API test.

#11 Updated by Dru Lavigne 9 months ago

  • Subject changed from Jails/Add/Wizard: "Release" drop-down menu no longer opens to Fix bad caching on list_resource in Jails Wizard in new UI
  • Category changed from GUI (new) to Middleware
  • Status changed from Passed Testing to Ready for Testing
  • Assignee changed from Erin Clark to Brandon Schneider
  • Needs Doc changed from Yes to No

#13 Updated by Eric Turgeon 9 months ago

  • Status changed from Ready for Testing to Passed Testing

#15 Updated by Dru Lavigne 9 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF