Project

General

Profile

Feature #37946

Umbrella #36938: Middleware task progress

Return progress for pool creation

Added by Erin Clark over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Medium
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Creating a pool takes a long time. The middleware should return progress on pool creation so that the user has an idea of the progress of a pool creation task


Related issues

Is duplicate of FreeNAS - Feature #35749: Convert Storage:Volume Manager to MiddlewaredReady for Testing
Copied from FreeNAS - Feature #36943: Add progress for iocage jail creation and fetching to middlewareDone

History

#1 Updated by Erin Clark over 1 year ago

  • Copied from Feature #36943: Add progress for iocage jail creation and fetching to middleware added

#2 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.3 to N/A
  • Reason for Closing set to Behaves as Intended

This is already implemented in 11.3. #35749 63d18069c8

#3 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Feature #35749: Convert Storage:Volume Manager to Middlewared added

Also available in: Atom PDF