Project

General

Profile

Bug #38155

Add default gateway interface to vnet jail bridge

Added by Sherman Uitzetter 12 months ago. Updated 11 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

My FreeNAS network interface is a link aggregation (lagg0). When I create an iocage jail with the VNET option, the resulting bridge interface (bridge0) only gets the iocage jail's interface (vnet0) added. My lagg0 interface isn't a member of the bridge. The result of this is that the jail has no network connectivity. I can manually add lagg0 to the bridge with "ifconfig bridge0 addm lagg0" and then the jail has network.


Related issues

Has duplicate FreeNAS - Bug #38743: Jail networking lost after upgrade to 11.2 Beta1Closed

Associated revisions

Revision ceea5da5 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared/jail): add default gateway interface to vnet jail bridge

Ticket: #38155

Revision 4fe4a261 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared/jail): add default gateway interface to vnet jail bridge

Ticket: #38155

Revision 209382d4 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared/jail): add default gateway interface to vnet jail bridge

Ticket: #38155

Revision 3888ead8 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared/jail): handle start/stop gracefully using iocage

Ticket: #38155

Revision ce646f68 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared): cancel all tasks only after all terminate calls

Ticket: #38155

Revision 8ce23c21 (diff)
Added by William Grzybowski 11 months ago

rm(middlwared/jail): let iocage handle default interface to bridge

Ticket: #38155

Revision a1c47144 (diff)
Added by William Grzybowski 11 months ago

rm(middlwared/jail): let iocage handle default interface to bridge

Ticket: #38155

Revision 6f416495 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared/jail): handle start/stop gracefully using iocage

Ticket: #38155

Revision 103ee290 (diff)
Added by William Grzybowski 11 months ago

fix(middlewared): cancel all tasks only after all terminate calls

Ticket: #38155

Revision 2fd3aacd (diff)
Added by William Grzybowski 11 months ago

rm(middlwared/jail): let iocage handle default interface to bridge

Ticket: #38155

History

#1 Updated by Dru Lavigne 12 months ago

  • Private changed from No to Yes

Sherman: please attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Sherman Uitzetter 12 months ago

  • File fndebug.tar.gz added

#3 Updated by Dru Lavigne 12 months ago

  • Category changed from OS to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Seen in changed from 11.1-U4 to 11.2-BETA1

#4 Updated by William Grzybowski 12 months ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-BETA2
  • Severity changed from New to Medium
  • Needs Merging changed from Yes to No

Brandon, not sure if we already have a tickets for this, can you investigate, please?

#5 Updated by Brandon Schneider 12 months ago

  • Status changed from Unscreened to Not Started

#6 Updated by Dru Lavigne 11 months ago

  • Has duplicate Bug #38743: Jail networking lost after upgrade to 11.2 Beta1 added

#7 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.2-BETA2 to 11.2-BETA3

#9 Updated by William Grzybowski 11 months ago

  • Status changed from Not Started to Closed
  • Target version changed from 11.2-BETA3 to N/A
  • Reason for Closing set to Duplicate Issue

I believe this one to be a duplicated

#10 Updated by William Grzybowski 11 months ago

  • Is duplicate of Bug #37870: Plugins will not install fail with {repo} could not be reached, please check your DNS added

#11 Updated by Dru Lavigne 11 months ago

  • File deleted (fndebug.tar.gz)

#12 Updated by Dru Lavigne 11 months ago

  • Private changed from Yes to No

#13 Updated by William Grzybowski 11 months ago

  • Status changed from Closed to In Progress
  • Assignee changed from Brandon Schneider to William Grzybowski
  • Target version changed from N/A to 11.2-BETA2

Turns out I dont think this one is a duplicated.

#14 Updated by William Grzybowski 11 months ago

  • Is duplicate of deleted (Bug #37870: Plugins will not install fail with {repo} could not be reached, please check your DNS )

#15 Updated by Bug Clerk 11 months ago

  • Status changed from In Progress to Ready for Testing
  • Target version changed from 11.2-BETA2 to 11.2-U2

#16 Updated by Disk Didler 11 months ago

Considering the quantity of posts on the forums, Reddit and here about plugins and networking, is this the correct target version for this job?

#17 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.2-U2 to 11.2-BETA2

#18 Updated by Dru Lavigne 11 months ago

  • Subject changed from iocage jail bridge interface doesn't get link aggregation interface added to Add default gateway interface to vnet jail bridge
  • Needs Doc changed from Yes to No

#19 Updated by Bug Clerk 11 months ago

  • Status changed from Ready for Testing to In Progress

#20 Updated by William Grzybowski 11 months ago

#21 Updated by Bug Clerk 11 months ago

  • Status changed from In Progress to Ready for Testing

#23 Updated by Bonnie Follweiler 11 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

#24 Updated by Dru Lavigne 11 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF