Project

General

Profile

Bug #38255

Update zsh to 5.5.1

Added by Ryan Moeller about 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

In a clean install of FreeNAS-11.2-MASTER-201807141306-2f3ee66.iso to a bhyve VM (tested with loader=bhyveload), the netcli "Console setup" menu on the serial console doesn't spawn a shell when the "Shell" menu entry is chosen. It just displays a warning that settings changed through the CLI won't be saved and then displays the menu again.


Related issues

Related to FreeNAS - Bug #38918: IPMI connection problems for FreeNAS MiniClosed

History

#1 Updated by Dru Lavigne about 2 years ago

  • Category changed from Console to OS
  • Assignee changed from Release Council to Alexander Motin

#2 Updated by Alexander Motin about 2 years ago

  • Subject changed from Console setup menu "Shell" entry doesn't work to zsh crashes on serial console
  • Assignee changed from Alexander Motin to William Grzybowski
  • Target version changed from Master - FreeNAS Nightlies to 11.2-RC2

I've reproduced this on physical machine too, so it is not a bhyve issue. zsh shell crashes when started on serial console with such truss syscall trace:

...
ioctl(10,TIOCSPGRP,0x7fffffffe93c)               = 0 (0x0)
fstat(0,{ mode=crw------- ,inode=116,size=0,blksize=4096 }) = 0 (0x0)
fcntl(0,F_GETFL,)                                = 2 (0x2)
sigprocmask(SIG_UNBLOCK,{ SIGWINCH },{ SIGWINCH }) = 0 (0x0)
sigprocmask(SIG_BLOCK,{ SIGWINCH },{ })          = 0 (0x0)
geteuid()                                        = 0 (0x0)
write(10,"\^[[1m\^[[7m#\^[[m\^[[1m\^[[m \r"...,23) = 23 (0x17)
sigaction(SIGINT,{ 0x4ab1f0 0x0 ss_t },0x0)      = 0 (0x0)
sigaction(SIGINT,{ 0x4ab1f0 0x0 ss_t },0x0)      = 0 (0x0)
geteuid()                                        = 0 (0x0)
ioctl(10,TIOCSPGRP,0x7fffffffe02c)               = 0 (0x0)
ioctl(10,TIOCSETAW,0x7fffffffe0a0)               = 0 (0x0)
write(10,"\r\^[[m\^[[m\^[[m\^[[J",13)            = 13 (0xd)
write(10,"\^[[K",3)                              = 3 (0x3)
write(10,"\^[[?2004h",8)                         = 8 (0x8)
write(10," \r",2)                                = 2 (0x2)
SIGNAL 8 (SIGFPE) code=FPE_INTDIV trapno=18 addr=0x801c5af09
process killed, signal = 8 (core dumped)

, while the same works just fine on a video console. csh (if you change root shell to it via WebUI) in the same situation works just fine, but if you run zsh from the csh, it still crashes.

It seems like newer zsh version 5.5.1 fixes that. William, could you as port committer update it please?

#3 Updated by William Grzybowski about 2 years ago

  • Category changed from OS to Middleware
  • Status changed from Unscreened to Screened
  • Target version changed from 11.2-RC2 to 11.2-BETA2

#4 Updated by William Grzybowski about 2 years ago

  • Status changed from Screened to In Progress

#5 Updated by William Grzybowski about 2 years ago

  • Status changed from In Progress to Ready for Testing

Acceptance Criteria
Make sure you can access shell (option 9) when using real serial console (not video)

#6 Updated by Dru Lavigne about 2 years ago

  • Subject changed from zsh crashes on serial console to Update zsh to 5.5.1
  • Needs Merging changed from Yes to No

#7 Updated by Alexander Motin about 2 years ago

Now zsh on serial console works for me. Thanks.

#8 Updated by Nick Wolff about 2 years ago

  • Status changed from Ready for Testing to Passed Testing

Zsh is working now tested via sol

#9 Updated by Nick Wolff about 2 years ago

root@freenas:~ # zsh --version
zsh 5.5.1 (amd64-portbld-freebsd11.0)
root@freenas:~ # uname -a
FreeBSD freenas.tn.ixsystems.com 11.2-STABLE FreeBSD 11.2-STABLE #0 8881beaaf(freenas/11-stable): Wed Jul 18 05:51:44 EDT 2018 :/freenas-11-nightlies/freenas/_BE/objs/freenas-11-nightlies/freenas/_BE/os/sys/FreeNAS.amd64 amd64
root@freenas:~ # cat /etc/version
FreeNAS-11.2-MASTER-201807180859 (ad5b897)

#10 Updated by Timothy Moore II about 2 years ago

  • Blocked by Bug #38918: IPMI connection problems for FreeNAS Mini added

#11 Updated by Timothy Moore II about 2 years ago

  • Related to Bug #38918: IPMI connection problems for FreeNAS Mini added

#12 Updated by Timothy Moore II about 2 years ago

  • Blocked by deleted (Bug #38918: IPMI connection problems for FreeNAS Mini)

#13 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No

Also available in: Atom PDF