Project

General

Profile

Feature #38719

Feature #36403: Add Let's Encrypt Support for Certs

Add Python packages needed for ACME integration

Added by Waqar Ahmed over 1 year ago. Updated 8 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Estimated time:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

Description

Following Python packages have to be added for integration of ACME in FreeNAS
1) josepy
2) acme
3) certbot-dns-digitalocean
4) certbot-dns-cloudfare

Associated revisions

Revision 3ad80147 (diff)
Added by William Grzybowski over 1 year ago

feat(ports): add acme/certbot required ports Ticket: #38719

Revision c61bbb73 (diff)
Added by William Grzybowski about 1 year ago

feat(ports): add acme/certbot required ports Ticket: #38719

Revision 5a384932 (diff)
Added by William Grzybowski about 1 year ago

feat(ports): add acme/certbot required ports Ticket: #38719

History

#1 Updated by Waqar Ahmed over 1 year ago

Adding two more popular certbot dns providers:
1) certbot-dns-google
2) certbot-dns-ovh

#2 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Screened

#3 Updated by William Grzybowski over 1 year ago

  • Severity changed from New to Medium

#4 Updated by Bug Clerk over 1 year ago

  • Status changed from Screened to In Progress

#5 Updated by Bug Clerk about 1 year ago

  • Status changed from In Progress to Ready for Testing

#6 Updated by William Grzybowski about 1 year ago

  • Status changed from Ready for Testing to Done
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Nothing to be tested here.

#7 Updated by Dru Lavigne about 1 year ago

  • Needs QA changed from Yes to No

#8 Updated by Dru Lavigne about 1 year ago

  • Subject changed from Python packages to be added to Add Python packages needed for ACME integration

#9 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.3 to 11.3-BETA1

#10 Updated by Dru Lavigne 8 months ago

  • Target version changed from 11.3-BETA1 to 11.3-ALPHA1

Also available in: Atom PDF