Project

General

Profile

Bug #38923

#27514 fix causes panic on dataset quota overflow

Added by Alexander Motin over 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Severity:
High
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

According to this FreeBSD bug report: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=229887 , fixing one problem created another, which may be even worse. If it won't be fixed in time, we may need to revert the original patch.


Related issues

Related to FreeNAS - Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnodeDone
Related to FreeNAS - Bug #41910: Fix system crash/freeze when deleting many filesDone

History

#1 Updated by Alexander Motin over 2 years ago

  • Related to Bug #27514: Break potential recursion involving getnewvnode and zfs_rmnode added

#2 Updated by Alexander Motin over 2 years ago

  • Description updated (diff)
  • Status changed from Unscreened to Screened

#4 Updated by Alexander Motin about 2 years ago

  • Target version changed from 11.2-BETA3 to 11.2-RC1

#5 Updated by Alexander Motin about 2 years ago

  • Related to Bug #41910: Fix system crash/freeze when deleting many files added

#6 Updated by Alexander Motin about 2 years ago

  • Status changed from Screened to In Progress

#7 Updated by Alexander Motin about 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Behaves as Intended
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

I've unexpectedly found during merge attempt from FreeBSD that this problem is not reproducible on FreeNAS, since Benno committed different patches to FreeNAS and FreeBSD. Still I've merged https://github.com/freenas/os/commit/a676a93fb3fb5edf660aed5f7c07a9de472a4d8d to remove divergence. Testing of #41910 should cover this too.

Also available in: Atom PDF