Project

General

Profile

Bug #39131

Handle disk wipe percentages correctly in new UI

Added by Jeremy Karst over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Erin Clark
Category:
Middleware
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Wiping a disk from the FreeNAS 11.2 STABLE train gives a GUI progress indicator that quickly progresses past 100%. (over 1000%)

See attached screenshot.

WipingDisk.JPG (66.7 KB) WipingDisk.JPG Jeremy Karst, 07/20/2018 01:08 PM
22219

Associated revisions

Revision 0ca5416f (diff)
Added by Erin Clark over 1 year ago

Handle disk wipe percentages correctly Ticket: #39131

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-BETA3

#2 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to Lola Yang

#3 Updated by Lola Yang over 1 year ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Lola Yang to William Grzybowski

#5 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Not Started

#7 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Waqar Ahmed

Waqar, can you investigate this one too, please?

Likely an easy math problem.

#8 Updated by Waqar Ahmed over 1 year ago

  • Status changed from Not Started to In Progress

#9 Updated by Waqar Ahmed over 1 year ago

  • Status changed from In Progress to Unscreened
  • Assignee changed from Waqar Ahmed to Erin Clark

Hello Erin. Kindly have a look at the payload which Middlewared returns -

{"msg": "changed", "collection": "core.get_jobs", "id": 4, "fields": {"id": 4, "method": "disk.wipe", "arguments": ["ada1", "FULL"], "logs_path": null, "logs_excerpt": null, "progress": {"percent": 19.793701171875, "description": null, "extra": {"speed": 842963030}}, "result": null, "error": null, "exception": null, "state": "RUNNING", "time_started": {"$date": 1533533472973}, "time_finished": null}}

The percentage is below 100, I think the issue is related to how new UI handles the progress in this case. Could you take a look please ? Thank you : )

#10 Updated by Erin Clark over 1 year ago

  • Status changed from Unscreened to In Progress

#11 Updated by Erin Clark over 1 year ago

  • Status changed from In Progress to Ready for Testing

#12 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Wiping disk progress in GUI reads >100% to Handle disk wipe percentages correctly in new UI
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#13 Updated by Bonnie Follweiler over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.2-MASTER-201808280901

#14 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF