Project

General

Profile

Bug #39223

Update RancherOS to 1.4

Added by Disk Didler over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Marcelo Araujo
Category:
OS
Target version:
Severity:
High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hi,

Can I ask a very silly question,
Why is FreeNAS pulling down version v1.1.3 (4.9.75 linux) release of RancherOS? for the DockerVM host?

Is there a specific reason? Is something hardcoded?
I'm almost positive this must be a duplicate of another job but I tried searching, couldn't find a specific job addressing this?

There's a thread discussing the DockerVM on the forums and it's a whole mess of misinformation, what is the official stance here? Is docker going to be supported under a (recent) VM in the future?

rancheros_version.png (27.7 KB) rancheros_version.png Aaron St. John, 08/10/2018 08:42 AM
rancher_error.png (191 KB) rancher_error.png Aaron St. John, 08/15/2018 07:24 AM
24064
24450

Related issues

Has duplicate FreeNAS - Bug #40452: VM Docker Host stil based on rancheros 1.1.3 - time to generate a new template?Closed
Has duplicate FreeNAS - Feature #41128: Doc let you install Rancher 1.6, whereas 2.0 is outClosed

Associated revisions

Revision ec1fe611 (diff)
Added by Marcelo Araujo over 1 year ago

- Update RancherOS to 1.4. Ticket: #39223

Revision eff936a7 (diff)
Added by Marcelo Araujo over 1 year ago

- Update RancherOS to 1.4. (#1650) Ticket: #39223

Revision 2c7dfe0f (diff)
Added by Dru Lavigne over 1 year ago

Mention bump in RancherOS version. Ticket: #39223

Revision f803fcca (diff)
Added by Dru Lavigne over 1 year ago

Mention bump in RancherOS version. Ticket: #39223

Revision ef35861d (diff)
Added by Marcelo Araujo over 1 year ago

- Update RancherOS to 1.4. Ticket: #39223

History

#1 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Release Council to Alexander Motin

#2 Updated by Alexander Motin over 1 year ago

  • Assignee changed from Alexander Motin to Marcelo Araujo

#3 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Bug #40452: VM Docker Host stil based on rancheros 1.1.3 - time to generate a new template? added

#4 Updated by Jelle Bekker over 1 year ago

I was trying to upgrade my rancher/server installation to 2.x but it seems like that requires version RancherOS 1.4. I would like to see this updated :-)

#5 Updated by Dru Lavigne over 1 year ago

  • Subject changed from FreeNAS Nightly, is still downloading 4.9.75 RancherOS (1.13?) to Update RancherOS to 1.4
  • Target version changed from Backlog to 11.2-BETA3

#6 Updated by Marcelo Araujo over 1 year ago

  • Status changed from Unscreened to In Progress
  • Severity changed from Low to High

#7 Updated by Dru Lavigne over 1 year ago

#8 Updated by Marcelo Araujo over 1 year ago

  • Status changed from In Progress to Ready for Testing

Merged and CDN updated.

#9 Updated by Dru Lavigne over 1 year ago

  • Needs Merging changed from Yes to No

#10 Updated by Dru Lavigne over 1 year ago

  • Has duplicate Feature #41128: Doc let you install Rancher 1.6, whereas 2.0 is out added

#11 Updated by Aaron St. John over 1 year ago

24064

Tested on FreeNAS-11.2-MASTER-201808090859

See screenshot.

#12 Updated by Aaron St. John over 1 year ago

24450

Seen in FreeNAS-11.2-MASTER-201808140859

I came back to this issue because I was going to update docs. I now receive an error when the rancherOS is being downloaded (see screenshot).

VM options I've set up:
1. VM Wizard type=Docker Host
2. Name=Rancher, Start on Boot=false
3. Virtual CPUs=2, Memory size=4000MiB
4. Adapter Type=Intel e82545 (e1000)
5. Raw filename=docker.img, Raw file size (GiB)=20, Disk sector size (Bytes)=0

I then attempt to start the VM. During the download process I would get the error (see screenshot).

UPDATE: After deleting the VM, refreshing the page, and trying again a few times it finally worked. Regardless I think this should still be looked into.

#13 Updated by Dru Lavigne over 1 year ago

  • Status changed from Blocked to Failed Testing

#14 Updated by Marcelo Araujo over 1 year ago

Aaron St. John wrote:

Seen in FreeNAS-11.2-MASTER-201808140859

I came back to this issue because I was going to update docs. I now receive an error when the rancherOS is being downloaded (see screenshot).

VM options I've set up:
1. VM Wizard type=Docker Host
2. Name=Rancher, Start on Boot=false
3. Virtual CPUs=2, Memory size=4000MiB
4. Adapter Type=Intel e82545 (e1000)
5. Raw filename=docker.img, Raw file size (GiB)=20, Disk sector size (Bytes)=0

I then attempt to start the VM. During the download process I would get the error (see screenshot).

UPDATE: After deleting the VM, refreshing the page, and trying again a few times it finally worked. Regardless I think this should still be looked into.

Hi,

So, basically when it was downloading the image, you clicked in "close" on the dialog box that shows the download progress bar and then you tried to start the VM again, is it?

Best,

#15 Updated by Aaron St. John over 1 year ago

Marcelo: Unfortunately that wasn't the case. I just let it run as normal. Ironically though I've ran into this same type of error when updating the system. For example, when I updated to the latest nightlies the progress stopped and the only thing the update progress tracker displayed was "docs". After trying a second time the update went through as normal. It seems that this bug is hard to reproduce as it doesn't happen consistently. One theory is that this specific system may be used by multiple people simultaneously at some given time. This fact might be a reason to unexplained issues.

I hope this helps.

#16 Updated by Marcelo Araujo over 1 year ago

Aaron St. John wrote:

Marcelo: Unfortunately that wasn't the case. I just let it run as normal. Ironically though I've ran into this same type of error when updating the system. For example, when I updated to the latest nightlies the progress stopped and the only thing the update progress tracker displayed was "docs". After trying a second time the update went through as normal. It seems that this bug is hard to reproduce as it doesn't happen consistently. One theory is that this specific system may be used by multiple people simultaneously at some given time. This fact might be a reason to unexplained issues.

I hope this helps.

Hi,

In my case here, I could not simulate it, I tried several rounds. It might be something else and not directly related with the update of RancherOS.

This update basically I created a new RancherOS image with the latest RancherOS version, updated the CDN and updated few parameters inside plugins/vm.py to point out to new Linux Kernel version and new initrd.

I'm not saying there is no issue, but definitely is something else. Maybe open a new ticket pointing out these two different errors that you had and we can keep tracking it.

Best,

#17 Updated by Dru Lavigne over 1 year ago

  • Status changed from Failed Testing to Passed Testing
  • Needs QA changed from Yes to No

#19 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done
  • Needs Doc changed from Yes to No

Also available in: Atom PDF