Project

General

Profile

Bug #39433

Account:Groups:Add need validators for GID and Name

Added by Michael Reynolds over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

GID field allows letters
Name field allows special characters

Both fields need validators

GID: Only allow 0-9
Name: Only allow alphanumeric

See Group-GID-Name-Fields-2018-07-24.png

Group-GID-Name-Fields-2018-07-24.png (27.9 KB) Group-GID-Name-Fields-2018-07-24.png Michael Reynolds, 07/24/2018 12:15 PM
22453

Related issues

Is duplicate of FreeNAS - Bug #39468: Prevent creation of groups with same name or GID in new UIDone
Has duplicate FreeNAS - Bug #40676: Duplicate user and group creation is behaving differentlyClosed

Associated revisions

Revision eb6d3a9c (diff)
Added by Erin Clark over 2 years ago

Add validators to group add/edit, use built in error handling Ticket: #39433 #39468

History

#1 Updated by Dru Lavigne over 2 years ago

  • Target version changed from Backlog to 11.2-BETA3

#2 Updated by Michael Reynolds over 2 years ago

This applies to Group -> Add and Group -> Edit

#3 Updated by Erin Clark over 2 years ago

  • Status changed from Unscreened to In Progress

#4 Updated by Erin Clark over 2 years ago

  • Related to Bug #39468: Prevent creation of groups with same name or GID in new UI added

#5 Updated by Dru Lavigne over 2 years ago

  • Related to deleted (Bug #39468: Prevent creation of groups with same name or GID in new UI)

#6 Updated by Dru Lavigne over 2 years ago

  • Is duplicate of Bug #39468: Prevent creation of groups with same name or GID in new UI added

#7 Updated by Dru Lavigne over 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.2-BETA3 to N/A
  • Reason for Closing set to Duplicate Issue

#8 Updated by Dru Lavigne about 2 years ago

  • Has duplicate Bug #40676: Duplicate user and group creation is behaving differently added

Also available in: Atom PDF