Project

General

Profile

Bug #39598

Make sure to UP VM bridge if it already exists

Added by Joe Maloney 9 months ago. Updated 9 months ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The bridge for VM's is down upon reboot of FreeNAS. This causes all network traffic for VM's to break until the bridge is enabled on the FreeNAS host. fn02.tn.ixsystems.com root abcd1234 can be used to reproduce the issue.

debug.tgz (2.69 MB) debug.tgz Joe Maloney, 07/25/2018 10:10 AM

Associated revisions

Revision 4f7d6693 (diff)
Added by William Grzybowski 9 months ago

fix(vm): make sure to UP bridge if it already exists

Ticket: #39598

Revision aaf44c21 (diff)
Added by William Grzybowski 9 months ago

fix(vm): make sure to UP bridge if it already exists

Ticket: #39598

History

#1 Updated by Joe Maloney 9 months ago

#2 Updated by Dru Lavigne 9 months ago

  • Category set to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Target version changed from Backlog to 11.2-BETA3

#4 Updated by Joe Maloney 9 months ago

It turns out this is not an issue when autostart is enabled. When autostart is disabled for all VMs the bridge does not come up when the VM starts.

#5 Updated by Bug Clerk 9 months ago

  • Status changed from Unscreened to In Progress

#6 Updated by Dru Lavigne 9 months ago

  • Target version changed from 11.2-BETA3 to 11.2-BETA2

#7 Updated by Dru Lavigne 9 months ago

  • Subject changed from Bridge is down upon reboot to Make sure to UP VM bridge if it already exists
  • Needs Doc changed from Yes to No

#8 Updated by Bug Clerk 9 months ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Dru Lavigne 9 months ago

  • Needs Merging changed from Yes to No

#10 Updated by Bonnie Follweiler 9 months ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test passed in FreeNAS-11.2-MASTER-201807270859
(Build Date: Jul 27, 2018 12:10)

#11 Updated by Dru Lavigne 9 months ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF