Project

General

Profile

Bug #39787

Allow boot scrub to run on passive/standby TrueNAS node

Added by Joshua Sirrine about 3 years ago. Updated almost 3 years ago.

Status:
Done
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Seen in:
TrueNAS - TrueNAS 11.1-U5.1
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

The default for boot device scrubs was lowered from 30 days to 7 days to help identify failing boot devices prematurely. It was noticed that scrubs on the boot devices are occurring on the active node as scheduled, but the passive node is not running any scrubs on its boot devices. Please make it so passive devices still scrub their disks appropriately.


Related issues

Copied to FreeNAS - Bug #59301: Allow boot scrub to run on passive nodeReady for Testing

Associated revisions

Revision 21804791 (diff)
Added by William Grzybowski almost 3 years ago

fix(scrub): allow freenas-boot scrub to run on passive/standby Ticket: #39787

Revision 392ea499 (diff)
Added by William Grzybowski almost 3 years ago

fix(scrub): allow freenas-boot scrub to run on passive/standby Ticket: #39787

Revision 3ee2877d (diff)
Added by William Grzybowski almost 3 years ago

fix(scrub): allow freenas-boot scrub to run on passive/standby Ticket: #39787 (cherry picked from commit 2180479135dc84d0f8d18dd9f444d7a7f975a4a9)

History

#1 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from 11.2-RC2 to Backlog

#4 Updated by Dru Lavigne almost 3 years ago

  • Assignee changed from Bill O'Hanlon to William Grzybowski

#5 Updated by William Grzybowski almost 3 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Scrub is ran using cron.

AFAIK cron is supposed to be running on standby. Can anyone verify if thats not the case?

#6 Avatar?id=14398&size=24x24 Updated by Kris Moore almost 3 years ago

  • Project changed from TrueNAS to FreeNAS
  • Category changed from HA to Middleware
  • Private changed from No to Yes
  • Migration Needed deleted (No)
  • Hide from ChangeLog deleted (No)
  • Support Department Priority deleted (0)

#7 Updated by Dru Lavigne almost 3 years ago

  • Target version changed from Backlog to 12.0

#8 Updated by Joshua Sirrine almost 3 years ago

I know it's not the case for some customers.. in this case I knew because when I did a "zpool history" and see a scrub hasn't occurred for months, since the passive node was passive for months, it's clear.

#9 Updated by William Grzybowski almost 3 years ago

  • Status changed from Blocked to Not Started
  • Target version changed from 12.0 to 11.3
  • Severity changed from New to Low Medium
  • Reason for Blocked deleted (Waiting for feedback)

We are probably restricting to MASTER node somehow then. But I do see it in crontab for both.

#10 Updated by Sam Fourman almost 3 years ago

We should attempt to reproduce this on a in house system.

#11 Updated by Bug Clerk almost 3 years ago

  • Status changed from Not Started to In Progress

#12 Updated by William Grzybowski almost 3 years ago

  • Target version changed from 11.3 to 11.2-U2

#13 Updated by Bug Clerk almost 3 years ago

  • Status changed from In Progress to Ready for Testing

#14 Updated by Bug Clerk almost 3 years ago

  • Target version changed from 11.2-U2 to 11.3

#15 Updated by Bug Clerk almost 3 years ago

  • Copied to Bug #59301: Allow boot scrub to run on passive node added

#16 Updated by Dru Lavigne almost 3 years ago

  • Subject changed from Make boot device scrubs happen on passive node to Allow boot scrub to run on passive/standby TrueNAS node
  • Status changed from Ready for Testing to Done
  • Target version changed from 11.3 to Master - FreeNAS Nightlies
  • Private changed from Yes to No

Also available in: Atom PDF