Project

General

Profile

Bug #40066

Fix nginx rule to correctly refresh plugins screen in new UI

Added by Rishabh Chauhan over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Severity:
Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Refer screenshots:
plugininstall(at plugin install page)
afterrefresh(redirected to old UI)

plugininstall.png (91.2 KB) plugininstall.png Rishabh Chauhan, 07/30/2018 07:40 AM
afterrefresh.png (126 KB) afterrefresh.png Rishabh Chauhan, 07/30/2018 07:40 AM
23136
23141

Associated revisions

Revision 9e4d5e28 (diff)
Added by Waqar Ahmed over 1 year ago

Nginx rule fix for plugins This commit fixes an issue where an unintended redirect was taking place when plugins was in the url. Ticket: #40066

History

#1 Updated by Erin Clark over 1 year ago

  • Assignee changed from Release Council to Lola Yang

Lola could you please look into this?

#2 Updated by Lola Yang over 1 year ago

  • Status changed from Unscreened to Screened

#3 Updated by Erin Clark over 1 year ago

  • Status changed from Screened to Unscreened
  • Assignee changed from Lola Yang to William Grzybowski

William: This appears to be caused by an nginx rule:

Line 281 of ix-nginx generates the following:

location ~ /(legacy|plugins|api/v1.0)/ {

If I remove the |plugins from that rule the issue goes away, however I don't know if that is how we want to fix things so I am passing this to you to see if you have any ideas.

#4 Updated by William Grzybowski over 1 year ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Target version changed from Backlog to 11.2-BETA3

#5 Updated by Waqar Ahmed over 1 year ago

  • Status changed from Unscreened to In Progress

#6 Updated by Waqar Ahmed over 1 year ago

  • Status changed from In Progress to Ready for Testing

#7 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Refreshing on the Plugin/Installed page redirects the UI to Legacy UI System Info page to Fix nginx rule to correctly refresh plugins screen in new UI
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#8 Updated by Bonnie Follweiler over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreeNAS-11.2-MASTER-201808300858

#9 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF