Project

General

Profile

Bug #40091

NetBIOS Name needs validator

Added by Michael Reynolds about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Erin Clark
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Services:SMB -> Configure -> NetBIOS Name

According to the tooltip the maximum characters allowed is 15
The field allows any number of characters.

Add a validator that only allows 15 or fewer characters


Related issues

Is duplicate of FreeNAS - Bug #40096: Add validation for NetBIOS Name and NetBIOS Alias fields in new UIDone

Associated revisions

Revision 104f1b7d (diff)
Added by Erin Clark about 2 years ago

Add length validators for netbios name and netbios alias Ticket: #40091 #40096

History

#1 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.2-BETA3

#2 Updated by Michael Reynolds about 2 years ago

Additional requirements for the validation

15char limit
the characters \/:*?"<>|. are not allowed
cannot consist of all digits
name cannot start or end with a -

The NetBIOS Alias field should have the same validator.

#3 Updated by Erin Clark about 2 years ago

  • Status changed from Unscreened to In Progress

#4 Updated by Dru Lavigne about 2 years ago

  • Is duplicate of Bug #40096: Add validation for NetBIOS Name and NetBIOS Alias fields in new UI added

#5 Updated by Dru Lavigne about 2 years ago

  • Status changed from In Progress to Closed
  • Target version changed from 11.2-BETA3 to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF