Project

General

Profile

Bug #40236

Fix disk sort size in Snapshot page of new UI

Added by Disk Didler almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
Low
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Specifically chose 1000 items per page so it has all snapshots.
Sorted by size.
A 400MB snapshot is 10 - 15 items down, yet a 97MB snapshot is at the top.

Bonus points.
Can anyone tell us, if we can safely delete those Warden migration jail snapshots?

Thanks team.

Seen in BETA1
https://i.imgur.com/sNA5vKQ.jpg


Related issues

Has duplicate FreeNAS - Bug #46234: Sorting on snapshot screen is alphabetic, even for columns that use numbersClosed

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

I can't reproduce this on BETA2. Once you have a chance to update later today, please leave a comment on this ticket whether or not you can still reproduce.

#2 Updated by Disk Didler almost 2 years ago

Reproduced right now, same thing.

I'd upload the screenshot but it's basically identical. Top item, 98.22MiB
10 or 15 items down, my "Sickrage warden migration snapshot" 401.06MiB

#3 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-BETA3

#4 Updated by Disk Didler almost 2 years ago

  • Subject changed from [UI, BETA1] Snapshot user interface, sort by size, is in fact, not sorting by size. to [UI, BETA2] Snapshot user interface, sort by size, is in fact, not sorting by size.
  • Seen in changed from 11.2-BETA1 to 11.2-BETA2

#5 Updated by Erin Clark almost 2 years ago

  • Assignee changed from Erin Clark to Dennis Mullen

#6 Updated by Dennis Mullen almost 2 years ago

  • Status changed from Unscreened to Screened

This table is part of the ngx-datatable package, which has its own built-in logic. Looks like it is doing kind of a pseudo-alphanumerical sort, with the nines, then the eights, etc. Will have to try to see if I can override the clickable column header somehow and connect it to a homemade sort function.

#7 Updated by Disk Didler almost 2 years ago

is it one of those things where it’s like
1
Vs
01
?

So 40mb would appear smaller than 900mb, because it’s not 040mb?

#8 Updated by Dennis Mullen almost 2 years ago

Yes, I think it is something like that. The table could handle the sort for straight numbers or letters, but the combination is throwing it off.

#9 Updated by Erin Clark almost 2 years ago

  • Target version changed from 11.2-BETA3 to 11.2-RC1

#10 Updated by Dennis Mullen almost 2 years ago

  • Status changed from Screened to In Progress

#11 Updated by Dennis Mullen almost 2 years ago

PR 1194

#12 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from [UI, BETA2] Snapshot user interface, sort by size, is in fact, not sorting by size. to Fix disk sort size in Snapshot page of new UI
  • Needs Doc changed from Yes to No

#13 Updated by Dru Lavigne almost 2 years ago

  • Reason for Blocked deleted (Need additional information from Author)

#14 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Bug #46234: Sorting on snapshot screen is alphabetic, even for columns that use numbers added

#15 Updated by Lola Yang almost 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#16 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing

Test Passed in FreeNAS-11.2-MASTER-201809281304

#17 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF