Project

General

Profile

Bug #40420

Fix issue with updating jails in new UI

Added by Jim Clark about 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

I stopped my jails I created in 11.2 beta1 and selected it to use 11.2 RELEASE instead and click save. I get a real quick popup that disappears very quick and I can't see what it says. The jail is then still using 11.1 RELEASE P8.

Screen Shot 2018-09-05 at 1.14.07 PM.png (18.2 KB) Screen Shot 2018-09-05 at 1.14.07 PM.png Bonnie Follweiler, 09/05/2018 10:15 AM
Screen Shot 2018-09-05 at 1.14.24 PM.png (44 KB) Screen Shot 2018-09-05 at 1.14.24 PM.png Bonnie Follweiler, 09/05/2018 10:15 AM
Screen Shot 2018-09-05 at 2.20.39 PM.png (62.9 KB) Screen Shot 2018-09-05 at 2.20.39 PM.png Bonnie Follweiler, 09/05/2018 11:33 AM
Screen Shot 2018-09-05 at 2.21.49 PM.png (26.5 KB) Screen Shot 2018-09-05 at 2.21.49 PM.png Bonnie Follweiler, 09/05/2018 11:33 AM
debug.tgz (129 KB) debug.tgz Bonnie Follweiler, 09/05/2018 02:10 PM
28477
28499
28543
28554

Related issues

Related to FreeNAS - Bug #45028: Show jail edit error message in a dialog in new UIDone
Related to FreeNAS - Bug #44834: Retry on pkg install failures to overcome transient network errors when installing PluginsDone
Has duplicate FreeNAS - Bug #41120: iocage update not working in 11.2 Beta 2Closed

History

#1 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Jim: please reproduce then attach a debug (System -> Advanced -> Save Debug) to this ticket.

#2 Updated by Jim Clark about 2 years ago

  • File debug.tgz added

#3 Updated by Dru Lavigne about 2 years ago

  • Category changed from OS to Middleware
  • Assignee changed from Release Council to William Grzybowski

#4 Updated by Jim Clark about 2 years ago

Jim Clark wrote:

I stopped my jails I created in 11.2 beta1 and selected it to use 11.2 RELEASE instead and click save. I get a real quick popup that disappears very quick and I can't see what it says. The jail is then still using 11.2 RELEASE P8.

Typo in original description, should read:
The jail is then still using 11.1 RELEASE P8

#5 Updated by William Grzybowski about 2 years ago

  • Description updated (diff)

#6 Updated by William Grzybowski about 2 years ago

  • Assignee changed from William Grzybowski to Brandon Schneider
  • Target version changed from Backlog to 11.2-BETA3
  • Reason for Blocked deleted (Need additional information from Author)

Brandon, users are not supposed to select/change RELEASE on jail edit, right?

#7 Updated by Brandon Schneider about 2 years ago

  • Status changed from Unscreened to Not Started

#8 Updated by Brandon Schneider about 2 years ago

  • Category changed from Middleware to GUI (new)
  • Assignee changed from Brandon Schneider to Erin Clark

AFAIK That is how they upgrade via the GUI, passing to Erin to investigate why it's not happening.

#9 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#10 Updated by Lola Yang about 2 years ago

  • Status changed from Not Started to In Progress

#11 Updated by William Grzybowski about 2 years ago

  • Has duplicate Bug #41120: iocage update not working in 11.2 Beta 2 added

#12 Updated by Erin Clark about 2 years ago

  • Status changed from In Progress to Ready for Testing

#13 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Updating jails from 11.2Beta1 to use 11.2 OS in 11.2Beta2 does nothing to Fix issue with updating jails in new UI
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#14 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug.tgz)

#15 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

#16 Updated by Bonnie Follweiler about 2 years ago

28477
28499

Test Failed in FreeNAS-11.2-MASTER-201809050856
I installed the jail in FreeNAS 11.2-Beta 1 upgraded to the nightlies and tried to update the release. It shows the spinner for about 10 seconds then it stays in the window and it doesn't save

#17 Updated by Bonnie Follweiler about 2 years ago

Added for clarification: I did a fresh install of FN 11.2-Beta1 - I created the jail selecting Release 11.1. I then updated to the Nightlies, edited the jail, and selected Release 11.2. I clicked the Save button. The spinner goes around a couple of times but it doesn't save the change and it doesn't close out the window

#18 Updated by Bonnie Follweiler about 2 years ago

28543
28554

On the Mac running Firefox in the New GUI there is no warning that the jail needs to be stopped before it can be edited and it opens the screen to edit but it wont save the changes

On Firefox/Ghost BSD After stopping the jail, in the Edit screen: switching from an older release (Release 11.1) to a newer release (Release 11.2) takes a while. After the spinner goes away it stays on the edit screen with an Error alert at the top of the screen: Error occurred, jail not upgraded
If you look at the jails it appears that the jail is on Release 11.2
(screenshots provided)

#19 Updated by Bonnie Follweiler about 2 years ago

#20 Updated by Lola Yang about 2 years ago

Bonnie Follweiler wrote:

On the Mac running Firefox in the New GUI there is no warning that the jail needs to be stopped before it can be edited and it opens the screen to edit but it wont save the changes

this part works for me. i use Firefox on my mac, it will popup an warning dialog if the jail is up.

#21 Updated by Lola Yang about 2 years ago

On Firefox/Ghost BSD After stopping the jail, in the Edit screen: switching from an older release (Release 11.1) to a newer release (Release 11.2) takes a while. After the spinner goes away it stays on the edit screen with an Error alert at the top of the screen: Error occurred, jail not upgraded
If you look at the jails it appears that the jail is on Release 11.2
(screenshots provided)

I can not reproduce this part too. it works properly for me.

#22 Updated by Erin Clark about 2 years ago

I tested this twice, once on my box with Firefox on Linux and it does show the error dialog while the jail is running and does not let me edit it. When I stopped the jail and tried upping the release from 11.1 to 11.2 it took a while but eventually succeded in updating the box. I tested on Lola's box and it did error out, however looking at the logs it would seem that it just failed in downloading one of the packages (perhaps network timeout?) but it did not do anything to the jail since it errored there.

Sep  5 10:04:07 freenas /netcli: [ws4py:360] Closing message received (1000) 'b'''
Sep  5 10:04:07 freenas /netcli: [urllib3.connectionpool:208] Starting new HTTP connection (1): 10.250.1.59
Sep  5 10:04:07 freenas /netcli: [urllib3.connectionpool:396] http://10.250.1.59:80 "HEAD / HTTP/1.1" 200 0
Sep  5 17:27:23 freenas /middlewared: [urllib3.connectionpool:824] Starting new HTTPS connection (1): www.freebsd.org
Sep  5 17:27:24 freenas /middlewared: [urllib3.connectionpool:396] https://www.freebsd.org:443 "GET /security/unsupported.html HTTP/1.1" 200 21406
Sep  5 17:27:24 freenas /middlewared: [urllib3.connectionpool:208] Starting new HTTP connection (1): download.freebsd.org
Sep  5 17:27:24 freenas /middlewared: [urllib3.connectionpool:396] http://download.freebsd.org:80 "GET /ftp/releases/amd64 HTTP/1.1" 301 178
Sep  5 17:27:24 freenas /middlewared: [urllib3.connectionpool:824] Starting new HTTPS connection (1): download.freebsd.org
Sep  5 17:27:25 freenas /middlewared: [urllib3.connectionpool:396] https://download.freebsd.org:443 "GET /ftp/releases/amd64 HTTP/1.1" 301 178
Sep  5 17:27:25 freenas /middlewared: [urllib3.connectionpool:396] https://download.freebsd.org:443 "GET /ftp/releases/amd64/ HTTP/1.1" 200 None

As far as I can tell it is doing the right thing although perhaps we want to reformat how the error is displayed if it fails?

#23 Updated by Dru Lavigne about 2 years ago

  • Status changed from Failed Testing to Ready for Testing

#25 Updated by Lola Yang about 2 years ago

  • Related to Bug #45028: Show jail edit error message in a dialog in new UI added

#28 Updated by Bonnie Follweiler about 2 years ago

  • Related to Bug #44834: Retry on pkg install failures to overcome transient network errors when installing Plugins added

#29 Updated by Bonnie Follweiler about 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Further fixes are coming on that ticket in RC1

#30 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF