Project

General

Profile

Bug #40424

USB boot drive issues

Added by Chris Adcock 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
Medium
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

First off, please refer to closed bug #40001. As such, I purchased 2 brand new 32GB flash drives, SanDisk USB 3.0 Ultra Fit. I go do the same thing, attempt to attach one of them to create a mirror. FreeNAS does it's thing and a message flashed at the top of the screen saying the drive is attached, but it is not. I attempted to do this several times with the same result...it says it is attached, but it simply does not attach. No errors, it just does not actually attach. What is the issue now?


Related issues

Related to FreeNAS - Bug #40001: USB boot issuesClosed
Is duplicate of FreeNAS - Bug #29277: Wait for zfs.pool.extend to complete so we can propagate errors when adding a mirrored USB driveDone

History

#1 Updated by Chris Adcock 10 months ago

  • File debug-AdcNAS-20180802020620.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne 10 months ago

#3 Updated by Dru Lavigne 10 months ago

  • Assignee changed from Release Council to William Grzybowski

#4 Updated by William Grzybowski 10 months ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Waiting for feedback

Is this the absolutely latest debug file?

I can see errors from your last attempt using smaller USB, but not this one.

#5 Updated by Chris Adcock 10 months ago

To the best of my knowledge this is inclusive of all attempts I've made using both larger and same size USB sticks. Is there something else you'd like me to include here? If so, please advise how to extract the information you require. Also note, I've tried to simply install the latest FreeNAS build and it always stops at the install page (I think that is referred to as the console page).

#6 Updated by William Grzybowski 10 months ago

  • Status changed from Blocked to Screened
  • Target version changed from Backlog to 11.2-BETA3
  • Severity changed from New to Medium

I was able to find the root cause from the logs, its a different issue.

It seems your freenas-boot zpool is using gptid for the disk name and the code is not expecting that (I am unsure why its using gptid instead of disk device name).
We will have to write some code to handle that case.

Depending on how intrusive it will be we can decide if its possible to backport to 11.1-U6.

#7 Updated by William Grzybowski 9 months ago

  • Status changed from Screened to Closed
  • Target version changed from 11.2-BETA3 to N/A
  • Reason for Closing set to Duplicate Issue

This was already fixed in 11.2-BETA1. Backporting the changes to 11.1 is too risky.

#8 Updated by William Grzybowski 9 months ago

  • Is duplicate of Bug #29277: Wait for zfs.pool.extend to complete so we can propagate errors when adding a mirrored USB drive added

#9 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-AdcNAS-20180802020620.txz)

#10 Updated by Dru Lavigne 9 months ago

  • Private changed from Yes to No
  • Reason for Blocked deleted (Waiting for feedback)

Also available in: Atom PDF