Project

General

Profile

Bug #40428

Pull in some recent FreeBSD fixes for ISO boot issues on legacy systems

Added by Tony Scicchitano about 2 years ago. Updated about 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Ryan Moeller
Category:
OS
Target version:
Seen in:
Severity:
Low Medium
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:

M5A78L-M LX PLUS
AMD FX-6300
16 GB DDR3 (ECC)
5 x 2TB SATA internal drives in raidz2 pool
1 x 4TB external USB drive
16GB USB system drive

ChangeLog Required:
No

Description

Tried a GUI upgrade from 11.1-U5 to 11.2-BETA2 and ended up with an unbootable system. Tried using the ISO and boot loader on installer seems to get stuck on a white screen with the following text:

BTX Version is 1.02
Consoles: internal video/kernel

I’ve tried multiple boot devices, and multiple install devices (verified SHA256 on download) and I’m always stuck on the same screen. I’m not sure what to do next.

3B695EA6-2511-42C4-946B-A5B9004ECE26.jpeg (7.94 MB) 3B695EA6-2511-42C4-946B-A5B9004ECE26.jpeg Tony Scicchitano, 08/01/2018 08:38 PM
traceback.jpg (1.47 MB) traceback.jpg Bonnie Follweiler, 08/28/2018 01:36 PM
23404
26403

Related issues

Related to FreeNAS - Bug #43273: While installing using a USB stick the installation stoped with an error messageClosed
Has duplicate FreeNAS - Bug #39308: Unable to install from usb disk to usb disk.Closed

History

#1 Updated by Tony Scicchitano about 2 years ago

  • File deleted (8D254945-0698-4F85-8407-E127DEF87BD8.jpeg)

#2 Updated by Tony Scicchitano about 2 years ago

  • Severity changed from Medium to New

#3 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Is the BIOS updated to its latest version? If it is, or if updating does not resolve the issue, please reboot into your previous boot environment, create a debug (System -> Advanced -> Save debug) and attach it to this ticket.

#4 Updated by Tony Scicchitano about 2 years ago

  • File debug-iserve-20180802182909.tgz added

BIOS is the latest version, so I’m attaching the debug.

Thx

#5 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Alexander Motin
  • Reason for Blocked deleted (Need additional information from Author)

#6 Updated by Alexander Motin about 2 years ago

  • Status changed from Unscreened to Screened

I do't remember I saw exactly the same screenshot before. It must be something new. As I understand you booted in legacy BIOS mode, right? Do you have exactly the same behavior when booting installer and installed (updated via Web) system? Have you tried UEFI on this system?

#7 Updated by Tony Scicchitano about 2 years ago

This result is from the 11.2-BETA2 ISO installer itself. I didn’t record it but I believe the same screen came up after upgrading via the web/GUI (11.1 installed using legacy BIOS mode).

Is there any value in trying UEFI install of 11.1-U5 and providing a debug?

#8 Updated by Tony Scicchitano about 2 years ago

Had some spare time and decided to try UEFI install of 11.1-U5 and it turns out this mobo doesn’t support it.

Main issue is I just can’t boot 11.2-BETA2 installation media.

#9 Updated by Alexander Motin about 2 years ago

  • Assignee changed from Alexander Motin to Ryan Moeller

#10 Updated by Ryan Moeller about 2 years ago

  • Status changed from Screened to In Progress
  • Severity changed from New to Low Medium
  • Needs QA changed from No to Yes
  • Needs Doc changed from No to Yes
  • Needs Merging changed from No to Yes

I'm able to reproduce this on one of my test systems (and indeed it is annoying me, too). So far I've traced the hang to the INT 13h probe and am looking into why that is happening.

As a workaround you should be able to boot the installer by unplugging the 4TB external USB drive until the kernel starts booting.

#11 Updated by Tony Scicchitano about 2 years ago

I still can’t boot the installer using the workaround. Stuck on the same screen.

#12 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-iserve-20180802182909.tgz)

#13 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.2-BETA3
  • Private changed from Yes to No

#14 Updated by Dru Lavigne about 2 years ago

  • Subject changed from Can’t boot ISO to Pull in some recent FreeBSD fixes for ISO boot issues on legacy systems
  • Status changed from In Progress to Ready for Testing
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#15 Updated by Dru Lavigne about 2 years ago

  • Has duplicate Bug #39308: Unable to install from usb disk to usb disk. added

#16 Updated by Ryan Moeller about 2 years ago

A regression was introduced in isoboot and gptboot which caused the incorrect argument format to be passed to loader, leading to memory corruption in the early boot process.
The regression was fixed upstream and I have cherry-picked the commit into FreeNAS.

Acceptance Criteria
This ticket describes the behavior exhibited by at least some versions of AMI BIOS for AMD processors. The system hangs indefinitely early in the boot process.
The fix should be tested by writing the ISO to a USB stick and booting in an affected system.
The expected behavior is for the system to boot normally without hanging early in the boot process.

The related issue describes booting with legacy BIOS and multiple USB drives. Rather than hanging as described in this ticket, these systems fail to detect the boot drive and drop to a loader prompt.
The fix should be tested by writing the ISO to a USB stick and booting in an affected system while another USB stick is also attached.
The expected behavior is for the system to boot normally without dropping to a loader prompt.

#17 Updated by Tony Scicchitano about 2 years ago

With respect to my original screenshot, I just wanted to point out that it’s not a prompt on the screen. No text input is possible.

Happy to test a nightly ISO if/when available.

#18 Updated by Ryan Moeller about 2 years ago

Tony Scicchitano wrote:

With respect to my original screenshot, I just wanted to point out that it’s not a prompt on the screen. No text input is possible.

Happy to test a nightly ISO if/when available.

Thanks, I'll clarify that part of my previous note. I am experiencing the same behavior on my M5A88-V EVO board with an FX-8320, and this has fixed the problem in that system, so I am optimistic that it will help in your case, too. This fix should make it into the next nightly that gets built.

#19 Updated by Tony Scicchitano about 2 years ago

Just tried today’s nightly and I was able to successfully boot the installer.

Thanks!

#20 Updated by Bonnie Follweiler about 2 years ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passed in FreNAS 11.2 Master-201808280901-ce081fe

#21 Updated by Bonnie Follweiler about 2 years ago

26403

As it started to install it got to the boot screen but before I could select the drive to install, etc it wont install
Screenshot provided:

#22 Updated by Bonnie Follweiler about 2 years ago

  • Status changed from Failed Testing to Passed Testing

Creating another ticket for the traceback issue since this one did start to install

#23 Updated by Dru Lavigne about 2 years ago

  • Status changed from Passed Testing to Done

#24 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #43273: While installing using a USB stick the installation stoped with an error message added

Also available in: Atom PDF