Project

General

Profile

Bug #4047

iSCSI Extent Addition Failing

Added by Michael Islek over 6 years ago. Updated about 3 years ago.

Status:
Closed: Duplicate
Priority:
Nice to have
Assignee:
-
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Request Method: GET
Request URL: https://fnas70.fti.cc/admin/services/iscsitargetextent/add/
Software Version: FreeNAS-9.2.1-BETA-3b5ea9f-x64
Exception Type: AttributeError
Exception Value:

'module' object has no attribute 'Volume'

Exception Location: /usr/local/www/freenasUI/../freenasUI/services/forms.py in _populate_disk_choices, line 1248
Server time: Wed, 29 Jan 2014 06:16:45 -0500
Traceback
Environment: Software Version: FreeNAS-9.2.1-BETA-3b5ea9f-x64 Request Method: GET Request URL: https://fnas70.fti.cc/admin/services/iscsitargetextent/add/ Traceback: File "/usr/local/lib/python2.7/site-packages/django/core/handlers/base.py" in get_response 107. response = middleware_method(request, callback, callback_args, callback_kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/middleware.py" in process_view 158. return login_required(view_func)(request, *view_args, **view_kwargs) File "/usr/local/lib/python2.7/site-packages/django/contrib/auth/decorators.py" in _wrapped_view 22. return view_func(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in wrapper 209. return self._admin.admin_view(view)(*args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/utils/decorators.py" in _wrapped_view 99. response = view_func(request, *args, **kwargs) File "/usr/local/lib/python2.7/site-packages/django/views/decorators/cache.py" in _wrapped_view_func 52. response = view_func(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/site.py" in inner 144. return view(request, *args, **kwargs) File "/usr/local/www/freenasUI/../freenasUI/freeadmin/options.py" in add 367. mf = mf() File "/usr/local/www/freenasUI/../freenasUI/services/forms.py" in init 1228. self.fields['iscsi_target_extent_disk'].choices = self._populate_disk_choices() File "/usr/local/www/freenasUI/../freenasUI/services/forms.py" in _populate_disk_choices 1248. for v in models.Volume.objects.all(): Exception Type: AttributeError at /admin/services/iscsitargetextent/add/ Exception Value: 'module' object has no attribute 'Volume'

Request information
GET

No GET data
POST

No POST data
FILES

No FILES data
COOKIES
Variable Value
csrftoken '5ZOeKNMTezgqchdYCRA7Y9hpRoJX7BGi'
sessionid 'op28qy5zl08jcb6ckju3b2o6jmxuv56i'
fntreeSaveStateCookie 'root%2Croot%2F8%2Croot%2F8%3FpreventCache%3D1390978708005%2Croot%2F8%3FpreventCache%3D1390978825563%2Croot%2F8%3FpreventCache%3D1390978840615%2Croot%2F8%3FpreventCache%3D1390978915367%2Croot%2F8%2F28%2Croot%2F1%2Croot%2F1%2F5%2Croot%2F1%2F2%2Croot%2F1%3FpreventCache%3D1390994012315%2Croot%2F8%3FpreventCache%3D1390994012324%2Croot%2F1%3FpreventCache%3D1390994202626%2Croot%2F8%3FpreventCache%3D1390994202632'
META
Variable Value
wsgi.multiprocess False
HTTP_REFERER 'https://fnas70.fti.cc/'
REDIRECT_STATUS '200'
SERVER_SOFTWARE 'nginx/1.4.4'
SCRIPT_NAME u''
REQUEST_METHOD 'GET'
PATH_INFO u'/admin/services/iscsitargetextent/add/'
SERVER_PROTOCOL 'HTTP/1.1'
QUERY_STRING ''
CONTENT_LENGTH ''
HTTP_USER_AGENT 'Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0'
HTTP_CONNECTION 'keep-alive'
HTTP_COOKIE 'csrftoken=5ZOeKNMTezgqchdYCRA7Y9hpRoJX7BGi; fntreeSaveStateCookie=root%2Croot%2F8%2Croot%2F8%3FpreventCache%3D1390978708005%2Croot%2F8%3FpreventCache%3D1390978825563%2Croot%2F8%3FpreventCache%3D1390978840615%2Croot%2F8%3FpreventCache%3D1390978915367%2Croot%2F8%2F28%2Croot%2F1%2Croot%2F1%2F5%2Croot%2F1%2F2%2Croot%2F1%3FpreventCache%3D1390994012315%2Croot%2F8%3FpreventCache%3D1390994012324%2Croot%2F1%3FpreventCache%3D1390994202626%2Croot%2F8%3FpreventCache%3D1390994202632; sessionid=op28qy5zl08jcb6ckju3b2o6jmxuv56i'
SERVER_NAME 'localhost'
REMOTE_PORT '63151'
wsgi.url_scheme 'https'
SERVER_PORT '443'
SERVER_ADDR '172.20.35.70'
DOCUMENT_ROOT '/usr/local/etc/nginx/html'
HTTP_X_REQUESTED_WITH 'XMLHttpRequest'
DOCUMENT_URI '/admin/services/iscsitargetextent/add/'
wsgi.input <flup.server.fcgi_base.InputStream object at 0x8100e7e90>
HTTP_HOST 'fnas70.fti.cc'
HTTPS 'on'
wsgi.multithread True
HTTP_CONTENT_TYPE 'application/x-www-form-urlencoded'
REQUEST_URI '/admin/services/iscsitargetextent/add/'
HTTP_ACCEPT 'text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8'
wsgi.version (1, 0)
GATEWAY_INTERFACE 'CGI/1.1'
wsgi.run_once False
wsgi.errors <flup.server.fcgi_base.TeeOutputStream object at 0x81012d190>
REMOTE_ADDR '172.20.40.10'
HTTP_ACCEPT_LANGUAGE 'en-US,en;q=0.5'
CONTENT_TYPE 'application/x-www-form-urlencoded'
CSRF_COOKIE u'5ZOeKNMTezgqchdYCRA7Y9hpRoJX7BGi'
HTTP_ACCEPT_ENCODING 'gzip, deflate


Related issues

Is duplicate of FreeNAS - Bug #4041: webUI Error --> add iSCSI extentClosed2014-01-28

History

#1 Updated by William Grzybowski over 6 years ago

  • Status changed from Unscreened to Closed: Duplicate

#2 Avatar?id=14398&size=24x24 Updated by Kris Moore about 3 years ago

  • Category set to OS
  • Target version changed from 49 to N/A
  • Seen in changed from to N/A

Also available in: Atom PDF