Project

General

Profile

Bug #40508

Misleading pool stats in New UI

Added by Chris Burge 12 months ago. Updated 4 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Problem: The pool stats header in the new ui is based on "zpool list" rather than "zfs list". As such this can be very misleading when datasets/zvols with reservations or refreservations exist in the pool. AFAIK, FreeNAs defaults to creating zvols with refreservation set to the zvol size used in the UI. The point is emphasised in this exmaple were a pool has only zvols. See attached images.

poolstats1.jpeg (33.3 KB) poolstats1.jpeg Chris Burge, 08/02/2018 08:32 AM
poolstat2.jpeg (51.9 KB) poolstat2.jpeg Chris Burge, 08/02/2018 08:32 AM
23492
23496

Related issues

Related to FreeNAS - Bug #39313: Free Space Not Accurate. Should take into account lost space for parity.Closed
Related to FreeNAS - Bug #76657: Fix pool free percentage in new UIDone
Is duplicate of FreeNAS - Bug #64728: Correctly display available and used space for datasets in new UIDone

History

#1 Updated by Dru Lavigne 12 months ago

  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-BETA3

#2 Updated by Erin Clark 12 months ago

  • Assignee changed from Erin Clark to Damian Szidiropulosz

#3 Updated by Erin Clark 12 months ago

  • Assignee changed from Damian Szidiropulosz to Erin Clark

#4 Updated by Erin Clark 12 months ago

  • Assignee changed from Erin Clark to William Grzybowski

#6 Updated by Erin Clark 12 months ago

  • Related to Bug #39313: Free Space Not Accurate. Should take into account lost space for parity. added

#7 Updated by William Grzybowski 11 months ago

  • Assignee changed from William Grzybowski to Erin Clark

#9 Updated by Dru Lavigne 11 months ago

  • Target version changed from 11.2-BETA3 to 11.3

#10 Updated by Erin Clark 4 months ago

  • Assignee changed from Erin Clark to Lola Yang

#12 Updated by Lola Yang 4 months ago

  • Is duplicate of Bug #64728: Correctly display available and used space for datasets in new UI added

#13 Updated by Lola Yang 4 months ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue

#14 Updated by Erin Clark 4 months ago

  • Related to Bug #76657: Fix pool free percentage in new UI added

#15 Updated by Dru Lavigne 4 months ago

  • Target version changed from 11.3 to N/A

Also available in: Atom PDF