Project

General

Profile

Bug #40600

FreeNAS crashes when modifying files shared with a jail

Added by Ashley Keep about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FreeNAS crashes and become completely unresponsive (requires reboot). It seems to occur when modifying files which are shared with a jail (PLEX). Does not occur with files that are not not shared with PLEX and does not occur with 11.2-BETA1


Related issues

Related to FreeNAS - Bug #41910: Fix system crash/freeze when deleting many filesDone

History

#1 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Ashley: please attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Ashley Keep about 2 years ago

  • File debug.tgz added

Hi. Debug as requested. I don't know how to get more information to you about the bug. All that i can tell you is that since upgrading to 11.2 beta 2, I can delete single files which are in a directory shared with Plex but if i try to delete multiple files in one go, my whole freenas machine becomes unresponsive, windows gives the error about the network drive not being available and i get the "Connecting to NAS... Make sure the NAS system is powered on and connected to the network" screen when i go to the FreeNAS gui and the only way to fix it is to reset my FreeNAS machine. Modifying and deleting a large number of files in a directory not shared with Plex works fine.

#3 Updated by Ashley Keep about 2 years ago

Correction. The problem is occurring when doing a mass delete of folders in any directory, not just the ones shared with Plex. I tried to delete around 100GB of files and it gets through a few tens or hundreds of MB and crashes the whole FreeNAS system and needs to be reset.

How do I get a system log to send you to diagnose the problem?

#4 Updated by Dru Lavigne about 2 years ago

It looks like your system is starting to stretch its resources due to 8GB of RAM and 78% disk capacity. Can you add more RAM? Can you add more disks to add another pool or replace the current disks with larger ones to increase capacity?

#5 Updated by Ashley Keep about 2 years ago

Hi. I realise that i'm running low on HDD space, which is why i tried to delete a large number of files which is what caused my whole freeNas machine to freeze, disconnect from my network and need to be force rebooted.
I've reverted back to 11.1 u5 and it works perfectly well, and i can bulk delete files without it crashing.
Whatever the bug is, it appears to be a problem with 11.2 and not 11.1.

#6 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Alexander Motin
  • Reason for Blocked deleted (Need additional information from Author)

#8 Updated by Alexander Motin about 2 years ago

  • Status changed from Unscreened to Blocked
  • Reason for Blocked set to Need additional information from Author

Ashley, could you tell more about how your system looks when it is not responsive? Does it respond on pings? Does it react on the console? Can you log in via via the console?

Have you been out of disk space or quota at some point during deletion? I have one problem to suspect, but in that case system would crash and reboot.

#9 Updated by Ashley Keep about 2 years ago

Hi. I was doing a mass delete of files when the progress bar stops and then windows gives the error about the file/folder not existing. The freenas disconnects from my network. The FreeNAS GUI shows "Connecting to NAS... Make sure the NAS system is powered on and connected to the network".
Pinging the FreeNAS IP (it's set to a static IP) times out. I plugged a monitor and keyboard into the FreeNAS box and it shows the standard console with the 14 options, but it is completely unresponsive to keyboard inputs.
I've left it like this for close to an hour hoping that it would recover but it doesn't. The only way to fix it is to power cycle the FreeNAS machine.

I realise that i don't have an ideal FreeNAS set up, but i'm new to this and learning before i go out and build a proper FreeNAS setup with more ram and drives. At the moment I'm just using an old PC which is maxed out at 8GB of ram and i have 1x 3TB hard drive and 1 pool which is at about 79% full (hence why i was trying to delete files). I have no quotas set and it never actually ran out of storage space. If i delete a single small file at a time, it worked but as soon as i tried to delete a folder which was several GB, it worked for a few seconds and Windows indicated that it deleted some of files before it just stopped and crashed. I reset the FreeNAS box and tried again and this crash occurred every time.

I've rolled back to 11.1 and it works perfectly well again and doesn't crash when i delete a large number of files.

#10 Updated by Alexander Motin about 2 years ago

  • Status changed from Blocked to Screened
  • Reason for Blocked deleted (Need additional information from Author)

Unfortunately without some info about the problem it is hard to say anything. If you could reproduce the problem after enabling debug kernel, may be it could crash the OS with some additional information instead of just hanging quietly.

#11 Updated by Alexander Motin about 2 years ago

  • Status changed from Screened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Ashley Keep wrote:

I was doing a mass delete of files when the progress bar stops and then windows gives the error about the file/folder not existing.

I've recently fixed issue hanging FreeNAS systems while deleting many files with extended attributes. It should be in coming soon 11.2-BETA3. Please try it when it is out and report if problem persist.

#12 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #41910: Fix system crash/freeze when deleting many files added

#13 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug.tgz)

#14 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF