Project

General

Profile

Bug #40916

Fix tooltip and table entry for Rsync Enabled setting

Added by Michael Reynolds over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Michael Reynolds
Category:
Documentation
Target version:
Severity:
New
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Tasks:Rsync Tasks -> Add -> Enabled checkbox

According to the rsync task Enabled checkbox tooltip
"When the Rsync service is OFF, the rsync task continues to look for the server unless Enabled is unset."

If Services:Rsync is Stopped, any configured rsync task that is enabled should be set to disabled
When the rsync service is started any rsync task that was enabled should be again enabled
Any rsync task that was already disabled when the rsync service was stopped should remain disabled

rsync_task_enable.png (154 KB) rsync_task_enable.png Aaron St. John, 08/23/2018 07:08 AM
25211

History

#1 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to William Grzybowski

#3 Updated by William Grzybowski over 1 year ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Behaves as Intended

I think you have a misunderstanding what Rsync service is. Its unrelated to Rsync tasks, they are completely independent.

Rsync service is to allow incoming rsync (without ssh).

#4 Updated by Dru Lavigne over 1 year ago

  • Category changed from GUI (new) to Documentation
  • Status changed from Closed to Unscreened
  • Assignee changed from William Grzybowski to Michael Reynolds
  • Target version changed from N/A to 11.2-BETA3

#6 Updated by Warren Block over 1 year ago

We will just delete that comment. It makes no sense, and it's difficult to tell what it was talking about. Maybe a confusion over whether a local rsync would find a running rsyncd to talk to, but it's hard to tell. If it ever comes up, maybe we can figure out what they were trying to say.

#7 Updated by Dru Lavigne over 1 year ago

  • Subject changed from An enabled rsync task will continue to look for a remote server if the rsync service is turned off to Fix tooltip and table entry for Rsync Enabled setting

#8 Updated by Michael Reynolds over 1 year ago

The tooltip was corrected in https://github.com/freenas/webui/pull/1096
user guide still needs to be updated

#9 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to In Progress

#10 Updated by Dru Lavigne over 1 year ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#12 Updated by Aaron St. John over 1 year ago

  • Needs Doc changed from Yes to No

(docs) angulargui branch PR: https://github.com/freenas/freenas-docs/pull/307

master branch PR: https://github.com/freenas/freenas-docs/pull/308

I hope I understood this correctly.

#13 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready for Testing to In Progress
  • Needs Doc changed from No to Yes

#14 Updated by Dru Lavigne over 1 year ago

  • Status changed from In Progress to Ready for Testing
  • Needs Doc changed from Yes to No

#15 Updated by Aaron St. John over 1 year ago

25211

Tested on FreeNAS-11.2-MASTER-201808230859

See screenshot. Tool tip is improved.

#16 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF