Project

General

Profile

Bug #41164

Domain Controller Not Found for domain

Added by Genya Kaplun about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Andrew Walker
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
User Configuration Error
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Error unable to find domain controller when enabling Active Directory Service.
Server 2012 R2 - DNS entry exists for Freenas. Able to ping Freenas from DC and DC from Freenas. Rebooted both.
Freenas Build FreeNAS-11.2-BETA2


Related issues

Related to FreeNAS - Bug #33453: Fix unnecessary AD restarts caused by enabling service monitorDone

History

#1 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Seen in changed from 11.2-U3 to 11.2-BETA2

Genya: please attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Genya Kaplun about 2 years ago

  • Subject changed from Domain Controller Not Found for domaon to Domain Controller Not Found for domain

#3 Updated by Genya Kaplun about 2 years ago

  • File debug-replicator-20180809154801.tgz added

#4 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to John Hixson

#5 Updated by Genya Kaplun about 2 years ago

I attached debug log. The log is from a differenet machine that's on 11.2 nightlies. It's the same issue however that appeared after the latest update. I booted original machine into 11 stable as its our production server. I will boot it into 11.2 and attach the debug log from that one later after hours today. However the issue is identical, on both after the update.
Machine I attached the log from is running FreeNAS-11.2-MASTER-201808090859

#6 Updated by Genya Kaplun about 2 years ago

Also please note that the issue disappeared as soon as I booted into 11 stable.

#7 Updated by John Hixson about 2 years ago

  • Status changed from Unscreened to Screened

try this from the command line:

sysctl freenas.directoryservice.activedirectory.dns.timeout=30
sysctl freenas.directoryservice.activedirectory.dns.lifetime=30

You can set these permanently in the tunable section of the UI

#8 Updated by Genya Kaplun about 2 years ago

Thanks,
I changed the setting and same issue/error - no effect

#9 Updated by John Hixson about 2 years ago

  • Assignee changed from John Hixson to Andrew Walker

#11 Updated by John Hixson about 2 years ago

  • Status changed from Screened to Unscreened

#12 Updated by Genya Kaplun about 2 years ago

  • File debug.tgz added

Here is the debug log from the 11.2 stable machine, I originally reported the issue from. I booted it into 11.2 and issue appeared again. Both machines are identical setup. One is 11.2 nightlies, this one is 11.2 stable. I am booting back into 11.1-u5 and will enable Active Directory Service (which should work under 11.1 no problem and will attach the log from that as well in case you find something helpful to compare the two scenarios.

#13 Updated by Genya Kaplun about 2 years ago

  • File debug-freenas-20180809180609.tgz added

Ok here is the debug from the same system booted into 11.1-u5 with active directory working upon the reboot. (didn't even have to enable it). So the issue is definitely with 11.2 and in 11.2- nightlies.
Please let me know if you need any more information.

#14 Updated by Andrew Walker about 2 years ago

Your resolv.conf looks like this:

+--------------------------------------------------------------------------------+
+                          /etc/resolv.conf @1533861499                          +
+--------------------------------------------------------------------------------+
search CBI.LOCAL
nameserver 192.168.192.12
nameserver 64.59.144.16
nameserver 8.8.8.8

Remove any nameserver that isn't appropriate for your AD environment (i.e. not a DC). I just merged this patch which should fix this behavior (rotating through NS1-NS3): https://github.com/freenas/freenas/pull/1614

But the resolv.conf is incorrect for an AD environment.

#15 Updated by Dru Lavigne about 2 years ago

  • Related to Bug #33453: Fix unnecessary AD restarts caused by enabling service monitor added

#16 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-replicator-20180809154801.tgz)

#17 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug.tgz)

#18 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-freenas-20180809180609.tgz)

#19 Updated by Dru Lavigne about 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No
  • Reason for Closing set to User Configuration Error

Also available in: Atom PDF