Project

General

Profile

Bug #41176

Avatar?id=13649&size=50x50

Bring new UI Reporting screen up to feature parity

Added by Ben Gadd almost 2 years ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Dennis Mullen
Category:
GUI (new)
Target version:
Seen in:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Problem Statement: Users are unable to see historical data in the reports.

Use Case: Expose historical data in the New UI so they are able to better determine why there was a performance change or other useful information that happened in the past.

User Story: As a User, I want the ability to see historical data in the reports, so that I can better determine why my system had a performance hit.

"Most of being a SysAdmin is knowing if what is happening now is different that what happened before and, if the answer is 'yes', figuring out when something changed. The new reporting interface only shows what is happening now. That is a failure. Without historical data, the current data is near worthless. I KNOW the system is slow NOW. What I want to know is when it started being slow and the new reports provide no help whereas the old reports gave me a year of knowledge."

Collected from FreeNAS Forum- https://forums.freenas.org/index.php?threads/freenas-11-2-beta2-is-now-available.68916/page-2#post-474708

Needs:
How long back do we expose?
Any changes to the new UI as far as a way to filter that information?
Able to export that information?


Related issues

Related to FreeNAS - Bug #26537: Add (correct) metrics to graphs in reporting sectionClosed
Has duplicate FreeNAS - Feature #42695: Need ability for charts to adjust time-scale / zoom outClosed
Has duplicate FreeNAS - Bug #47774: Reports button in Memory tile of Dashboard should link to Memory tab of reportsClosed
Has duplicate FreeNAS - Feature #23769: Option for small graphs (and small graphs in 2-4 columns) in "reporting"Closed
Copied to FreeNAS - Bug #51436: Fix forward/back buttons in Reporting section of new UIDone

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from 11.2-RC1 to 11.2-RC2

#3 Updated by Erin Clark almost 2 years ago

24024

So I think what they are asking for is the << and >> buttons as seen in the attached screenshot

#4 Updated by Erin Clark almost 2 years ago

  • Assignee changed from Erin Clark to Damian Szidiropulosz

#5 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Feature #42695: Need ability for charts to adjust time-scale / zoom out added

#7 Avatar?id=13649&size=24x24 Updated by Ben Gadd almost 2 years ago

Damian, can you also update the ticket to the appropriate status? I assume it has been screened at this point. :)

#8 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Bug #47774: Reports button in Memory tile of Dashboard should link to Memory tab of reports added

#9 Updated by Dru Lavigne almost 2 years ago

  • Has duplicate Feature #23769: Option for small graphs (and small graphs in 2-4 columns) in "reporting" added

#10 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Expose Historical Data in the New UI to Bring new UI Reporting screen up to feature parity
  • Status changed from Unscreened to In Progress
  • Target version changed from 11.2-RC2 to 11.2-RC1

This ticket covers the following improvements:
- assign paths to tabs so users can bookmark individual tabs in Reports page
- provide more layout options to user
- correct labels for graphs
- provide the ability to view historical graphing data (magnifying glass tool from legacy UI)

#11 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #26537: Add (correct) metrics to graphs in reporting section added

#12 Updated by Dru Lavigne almost 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#13 Updated by Jeff Ervin over 1 year ago

34550
34561
34572
34583

Test Fails FreeNAS-11.2-INTERNAL24

- assign paths to tabs so users can bookmark individual tabs in Reports page (passes)
- provide more layout options to user (passes)
- correct labels for graphs (fails: see screenshot)
- provide the ability to view historical graphing data (magnifying glass tool from legacy UI)** (passes)**

#14 Updated by Lola Yang over 1 year ago

  • Status changed from Failed Testing to Screened

Damian, could you take a look? thanks

#15 Updated by Lola Yang over 1 year ago

  • Assignee changed from Damian Szidiropulosz to Dennis Mullen

Lola Yang wrote:

Damian, could you take a look? thanks

Since Damian is off this week. Dennis will take a look. The issue is the bottom labels with a fixed width, not dynamically fit the content.

#16 Updated by Samantha Bonham over 1 year ago

  • Needs Doc changed from Yes to No

#18 Updated by Dru Lavigne over 1 year ago

  • Needs Merging changed from No to Yes

#19 Updated by Dru Lavigne over 1 year ago

Docs PR [angulargui]: https://github.com/freenas/freenas-docs/pull/396. This is in response to a change in the new UI so [master] does need to be updated.

#21 Updated by Dennis Mullen over 1 year ago

  • Status changed from Screened to In Progress

#22 Updated by Lola Yang over 1 year ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#23 Updated by Jeff Ervin over 1 year ago

I was able to pass the following for this ticket:

- assign paths to tabs so users can bookmark individual tabs in Reports page - (passes)
- provide more layout options to user (passes)
- correct labels for graphs (passed with INTERNAL 25)
- provide the ability to view historical graphing data (magnifying glass tool from legacy UI) Magnifying tool works, but back/forward buttons do not.

Having spoken with Damien, this fix will be in 11.2. Creating a ticket for this issue.

#24 Updated by Jeff Ervin over 1 year ago

  • Copied to Bug #51436: Fix forward/back buttons in Reporting section of new UI added

#25 Updated by Jeff Ervin over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Test Passes FreeNAS-11.2-INTERNAL25

#26 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF