Project

General

Profile

Bug #41256

vlan-form.component.ts needs a review to bring it to the latest coding standards

Added by Michael Reynolds over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Looks like the file webui/src/app/pages/network/vlans/vlan-form/vlan-form.component.ts was somehow
missed when the tooltips and other items were updated.

The old "tooltip: 'foo'," format is still used instead of the "tooltip: T('foo')," format

Here's the code block for the VLAN Description field for an example.

{
  type : 'input',
  name : 'vlan_description',
  placeholder : 'Description',
  tooltip : 'Enter any notes about this vlan.',
},

I've updated what I was able to/knew about. Mostly the tooltips and placeholders.
We need a dev to review.


Related issues

Is duplicate of FreeNAS - Bug #37606: Add missing and updated tooltips or fieldsDone

History

#1 Updated by Dru Lavigne over 1 year ago

  • Target version changed from Backlog to 11.2-RC1

#2 Updated by Erin Clark over 1 year ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

Vlans just needs translation markers but we should probably create a helptext file for it like in ticket 34086

#3 Updated by Vaibhav Chauhan over 1 year ago

  • Is duplicate of Bug #37606: Add missing and updated tooltips or fields added

#4 Updated by Vaibhav Chauhan over 1 year ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-RC1 to N/A

closed as its a duplicate.

#5 Updated by Dru Lavigne over 1 year ago

  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF