Project

General

Profile

Bug #41292

System crashes when deleting files

Added by Arch Willingham about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I just upgraded from 11.1 ver 5 to 11.2 Beta2. When deleting files from on of the datasets, the system crashes.

I can't see the actual box when it dies beacuse I working remotely. After about ten minutes I can log in.


Related issues

Related to FreeNAS - Bug #41910: Fix system crash/freeze when deleting many filesDone
Is duplicate of FreeNAS - Bug #40820: 11.2 Beta2 - system lock up when deleting filesClosed

History

#1 Updated by Arch Willingham about 2 years ago

  • File debug-freenas1-20180812022335.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne about 2 years ago

  • Category changed from Hardware to OS
  • Assignee changed from Release Council to Alexander Motin

#3 Updated by Alexander Motin about 2 years ago

  • Is duplicate of Bug #40820: 11.2 Beta2 - system lock up when deleting files added

#4 Updated by Alexander Motin about 2 years ago

  • Status changed from Unscreened to Screened
  • Target version changed from Backlog to 11.2-BETA3

It seems to be a duplicate of ticket #40820. As I see your system hanged and was rebooted by watchdog timer:

  17 | 08/12/2018 | 00:30:58 | Watchdog2 Watchdog | Hard reset | Asserted
  18 | 08/12/2018 | 00:42:30 | Watchdog2 Watchdog | Hard reset | Asserted

Unfortunately hardware watchdog reboot does not provide any additional debugging information, so if you get any more relevant data, please submit.

#5 Updated by Arch Willingham about 2 years ago

Alexander Motin wrote:

It seems to be a duplicate of ticket #40820. As I see your system hanged and was rebooted by watchdog timer:
[...]

Unfortunately hardware watchdog reboot does not provide any additional debugging information, so if you get any more relevant data, please submit.

That's pretty cool about the watchdog timer...didn't know it would do that.

Just weird that it only happens when deleting a bunch of file. I'll start deleting a bunch vs via this command "rm -v -rf '/mnt/vol0001/smbdata/CBB_ICONDC02/I$" , sometimes it runs for ten seconds...sometimes up to 45 seconds then it reboots. I wait for it to reboot then issue the commend again. Rinse and repeat.

I'm almost finished deleting them but stopped pending this bug report in case there was something ya'll wanted me to check.

#6 Updated by Dru Lavigne about 2 years ago

  • Target version changed from 11.2-BETA3 to 11.2-RC1

#7 Updated by Alexander Motin about 2 years ago

  • Related to Bug #41910: Fix system crash/freeze when deleting many files added

#8 Updated by Alexander Motin about 2 years ago

  • Status changed from Screened to Closed

Closing this as duplicate of #41910, first provided required information. I've reproduced the issue and working on the patch.

#9 Updated by Alexander Motin about 2 years ago

  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#10 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-freenas1-20180812022335.txz)

#11 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

Also available in: Atom PDF