Project

General

Profile

Bug #41304

Unable to run alert source 'HasUpdate'

Added by Don Craig about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

(Getting these alerts in 11.2-BETA2:)
New alerts:
  • Unable to run alert source 'HasUpdate'
    Traceback (most recent call last):
    File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/alert.py", line 352, in run_source
    alerts = (await alert_source.check()) or []
    File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 129, in throw
    return self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python3.6/site-packages/middlewared/alert/base.py", line 96, in check
    return await self.middleware.run_in_thread(self.check_sync)
    File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 129, in throw
    return self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 905, in run_in_thread
    return await self.run_in_executor(self.__threadpool, method, *args, **kwargs)
    File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 129, in throw
    return self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 902, in run_in_executor
    return await loop.run_in_executor(pool, functools.partial(method, *args, **kwargs))
    File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
    File "/usr/local/lib/python3.6/site-packages/middlewared/plugins/../alert/source/update.py", line 32, in check_sync
    path = self.middleware.call_sync("notifier.get_update_location")
    File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 1043, in call_sync
    return fut.result()
    File "/usr/local/lib/python3.6/concurrent/futures/_base.py", line 425, in result
    return self.__get_result()
    File "/usr/local/lib/python3.6/concurrent/futures/_base.py", line 384, in _get_result
    raise self._exception
    File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 967, in _call
    return await run_method(methodobj, *args)
    File "/usr/local/lib/python3.6/asyncio/coroutines.py", line 129, in throw
    return self.gen.throw(type, value, traceback)
    File "/usr/local/lib/python3.6/site-packages/middlewared/main.py", line 913, in run_in_io_thread
    return await self.loop.run_in_executor(executor, functools.partial(method, *args, **kwargs))
    File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
    File "/usr/local/www/freenasUI/middleware/notifier.py", line 1582, in get_update_location
    with client as c:
    File "/usr/local/www/freenasUI/middleware/client.py", line 20, in __enter

    local.client = Client()
    File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py", line 314, in init
    raise e
    File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py", line 307, in init
    self._ws.connect()
    File "/usr/local/lib/python3.6/site-packages/middlewared/client/client.py", line 169, in connect
    rv = super(WSClient, self).connect()
    File "/usr/local/lib/python3.6/site-packages/ws4py/client/
    _init__.py", line 215, in connect
    bytes = self.sock.recv(128)
    socket.timeout: timed out

Related issues

Related to FreeNAS - Bug #69159: Increase SQLite retry timeout to prevent locking on slow USB devicesDone
Is duplicate of FreeNAS - Bug #41365: Avoid sending dozens of crash reports filling up thread poolDone

History

#1 Updated by Dru Lavigne about 1 year ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Don: please attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Don Craig about 1 year ago

  • File debug.tgz added

As requested.
dmc

#3 Updated by Dru Lavigne about 1 year ago

  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#4 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

#5 Updated by William Grzybowski about 1 year ago

  • Is duplicate of Bug #41365: Avoid sending dozens of crash reports filling up thread pool added

#6 Updated by William Grzybowski about 1 year ago

I believe this is a side effect of #41365

Can you verify if you will still get these if you stop using the webUI for a while? (close the tab in the browser)

#7 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug.tgz)

#8 Updated by Dru Lavigne about 1 year ago

  • Private changed from Yes to No

#9 Updated by Derek Atkins 8 months ago

  • Seen in changed from 11.2-BETA2 to 11.2-RELEASE

Hi,

I am still seeing this behavior in 11.2 release:

root@freenas:~ # uname -a
FreeBSD freenas.ihtfp.org 11.2-STABLE FreeBSD 11.2-STABLE #0 r325575+fc3d65faae6(HEAD): Thu Dec 20 16:12:30 EST 2018 :/freenas-releng-final/freenas/_BE/objs/freenas-releng-final/freenas/_BE/os/sys/FreeNAS.amd64 amd64

#10 Updated by Dru Lavigne 8 months ago

  • Related to Bug #69159: Increase SQLite retry timeout to prevent locking on slow USB devices added

#11 Updated by Dru Lavigne 8 months ago

Derek: U2 will have an additional fix for this (see related ticket) but it looks like the real cause is a slow boot device.

Also available in: Atom PDF