Project

General

Profile

Bug #41316

Error in nginx.conf has broken the nightlies

Added by Jurgen Segaert about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
Build system
Target version:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

When booting up from the nightlies, one ends up being unable to connect to the UI.
Last seen on FreeNAS-11.2-MASTER-201808120839 but this has been going on for 4-5 days or so.
Trying to restart all services shows this:

root@freenas:~ # service -R
ataidle not running?
Stopping collectd.
minio not running? (check /var/run/minio.pid).
Stopping mdnsd.
Stopping dbus.
nginx not running? (check /var/run/nginx.pid).
Stopping pbid...
Stopping openssh.
Stopping syslog_ng.
Waiting for PIDS: 5639.
Starting syslog_ng.
Performing sanity check on openssh configuration.
Starting openssh.
Starting pbid...
Performing sanity check on nginx configuration:
nginx: [emerg] invalid condition "~" in /usr/local/etc/nginx/nginx.conf:104
nginx: configuration file /usr/local/etc/nginx/nginx.conf test failed
Starting nginx.
nginx: [emerg] invalid condition "~" in /usr/local/etc/nginx/nginx.conf:104
/usr/sbin/service: WARNING: failed to start nginx
Starting dbus.
Starting mdnsd.
install: mkdir : No such file or directory
/usr/sbin/service: WARNING: failed precmd routine for minio
Starting collectd.
plugin_load: plugin "aggregation" successfully loaded.
plugin_load: plugin "cpu" successfully loaded.
plugin_load: plugin "cputemp" successfully loaded.
plugin_load: plugin "ctl" successfully loaded.
plugin_load: plugin "df" successfully loaded.
plugin_load: plugin "disk" successfully loaded.
plugin_load: plugin "exec" successfully loaded.
plugin_load: plugin "geom_stat" successfully loaded.
plugin_load: plugin "interface" successfully loaded.
plugin_load: plugin "load" successfully loaded.
plugin_load: plugin "memory" successfully loaded.
plugin_load: plugin "network" successfully loaded.
plugin_load: plugin "processes" successfully loaded.
plugin_load: plugin "python" successfully loaded.
plugin_load: plugin "rrdtool" successfully loaded.
plugin_load: plugin "swap" successfully loaded.
plugin_load: plugin "uptime" successfully loaded.
Setting up system for textdumps.
debug.ddb.textdump.pending: 1 -> 1
debug.debugger_on_panic: 1 -> 1
debug.ddb.capture.bufsize: 4194304 -> 4194304

Removing the invalid if statement on line 104 in nginx.conf allows to proceed. Can somebody take a look?

        location /ui {
#            if (  ~ ^POST$ ) {
#                proxy_pass http://127.0.0.1:6000;
#            }
            try_files $uri $uri/ /index.html =404;
            alias /usr/local/www/webui;
        }


Related issues

Is duplicate of FreeNAS - Bug #41296: Fix nginx escape that prevented access to web UI in NightliesDone

History

#1 Updated by Jurgen Segaert about 3 years ago

Looks like this was already reported here: https://redmine.ixsystems.com/issues/41296
Sorry for the noise! :-)

#2 Updated by Jurgen Segaert about 3 years ago

  • Status changed from Unscreened to Closed

#3 Updated by Dru Lavigne about 3 years ago

  • Is duplicate of Bug #41296: Fix nginx escape that prevented access to web UI in Nightlies added

#4 Updated by Dru Lavigne about 3 years ago

  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF