Project

General

Profile

Bug #41435

Allow netgroups in NFS share authorized hosts and IP addresses

Added by . Hokan over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

With the upgrade to 11.2 beta 2 I can no longer enter a netgroup name in "authorized hosts and IP addresses" in "Unix (NFS) shares" with either the new or legacy UI.


Related issues

Related to FreeNAS - Bug #45321: Update documentation and help text to reflect a netgroup can be used for NFS shares Authorized Hosts and IP addresses fieldClosed
Related to FreeNAS - Feature #15247: Support for LDAP directory nested netgroupsClosed

Associated revisions

Revision 6afeabf9 (diff)
Added by Vladimir Vinogradenko over 1 year ago

Allow netgroups in NFS share authorized hosts and IP addresses Ticket: #41435

Revision 9e1d7394 (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(nfs): Disable checking hostname existence allowing netgroups to be used Ticket: #41435

Revision 0a89dc22 (diff)
Added by Vladimir Vinogradenko over 1 year ago

fix(nfs): Disable checking hostname existence allowing netgroups to be used Ticket: #41435

History

#1 Updated by . Hokan over 1 year ago

Error message is "Unable to resolve host".

#2 Updated by Dru Lavigne over 1 year ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Hokan: please attach a debug (System -> Advanced -> Save debug) to this ticket to assist the dev in determining the cause.

#3 Updated by . Hokan over 1 year ago

  • File debug.tgz added

Dru Lavigne wrote:

Hokan: please attach a debug (System -> Advanced -> Save debug) to this ticket to assist the dev in determining the cause.

#4 Updated by Dru Lavigne over 1 year ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#6 Updated by William Grzybowski over 1 year ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Target version changed from Backlog to 11.2-BETA3

Vladimir, can you investigate, please?

#7 Updated by Bug Clerk over 1 year ago

  • Status changed from Unscreened to In Progress

#8 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Can't share to a netgroup to Allow netgroups in NFS share authorized hosts and IP addresses
  • Private changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#10 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug.tgz)

#11 Updated by . Hokan over 1 year ago

I looked over the patch (I'm not a Python coder) and have a concern; FreeBSD doesn't normally used @ in /etc/exports.

It looks like your intention is to identify netgroup names by using an at sign (@) as a prefix. While this does work, this usage is not documented in the FreeBSD exports man page and differs from previous FreeNAS usage.

If the concern is providing for hostname error checking then, perhaps, if an entry does not resolve to a DNS hostname, test to see if a netgroup exists by the same name. Then you would not have to just skip entries beginning with @ and would be saved from a non-standard "@netgroup" entries in /etc/exports.

#12 Updated by Bug Clerk over 1 year ago

  • Status changed from Ready for Testing to In Progress

#13 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#14 Updated by Timothy Moore II over 1 year ago

  • Needs Doc changed from No to Yes

#16 Updated by Timothy Moore II over 1 year ago

  • Related to Bug #45321: Update documentation and help text to reflect a netgroup can be used for NFS shares Authorized Hosts and IP addresses field added

#17 Updated by Bonnie Follweiler over 1 year ago

  • Status changed from Ready for Testing to Done

Hokan: Please try this again after the FreeNAS 11.2-Beta3 upgrade on your system and add a comment to this ticket if the issue persists.

#18 Updated by Timothy Moore II over 1 year ago

  • Related to Feature #15247: Support for LDAP directory nested netgroups added

#19 Updated by Dru Lavigne over 1 year ago

  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No

Also available in: Atom PDF