Project

General

Profile

Bug #41610

Avatar?id=24324&size=50x50

Transmission plug-in doesn't save download directory

Added by Erik Koennecke about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Martin Wilke
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Fresh install of transmission plug-in via WebUI. In the settings, the download directory is only in memory - a stopped or restarted transmission process, jail, or system defaults to the directory /usr/local/etc/transmission/home/Downloads again. This happens after startup of the transmission process, the other changes in settings.json don't have this problem.

Steps to replicate:

  1. Install plug-in
  2. Stop transmission process (every method is OK; GUI, iocage console, ...)
  3. Edit settings.json to desired values of download-dir
  4. Restart transmission process ---> download-dir gets changed to default

Workaround:

  1. Apply change from within the transmission WebUI while running transmission. Change is in memory as long as process is running, but doesn't survive service restarts.

See also https://forums.freenas.org/index.php?threads/transmission-watch-directory.68930/#post-475443


Related issues

Is duplicate of FreeNAS - Bug #44317: Fix download directory setting in Transmission PluginDone

History

#1 Updated by Dru Lavigne about 2 years ago

  • Category changed from Services to GUI (new)
  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-RC1

#3 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

#4 Updated by Lola Yang about 2 years ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Lola Yang to Martin Wilke

Hi Martin, Could you take a look?

#5 Updated by Dru Lavigne about 2 years ago

  • Category changed from Middleware to OS

#6 Updated by Martin Wilke almost 2 years ago

  • Status changed from Unscreened to Ready for Testing

#8 Updated by Dru Lavigne almost 2 years ago

  • Is duplicate of Bug #44317: Fix download directory setting in Transmission Plugin added

#9 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Ready for Testing to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Duplicate Issue

Erik: the fix for 11.2-RC1 is in the related ticket.

Also available in: Atom PDF