Project

General

Profile

Bug #41676

FreeNAS 11.2-Beta2 unable to boot

Added by Flole Systems about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
No priority
Assignee:
Release Council
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Need additional information from Author
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,

I tried to Upgrade by FreeNas 11.1-U4 to 11.2-BETA2, but it failed miserably. After the Upgrade, the new Bootloader appeared but as soon as it tried to boot, it got stuck after loading the kernel (the bottom of the bootloader was still visible). My first thought was that something in the Upgrade Process might have caused the issue, so I tried to use a USB Drive with 11.2-Beta2 again, but that failed at the same bootstage as the normal boot. So something is not working well with the kernel and my computer. Enabling Verbose mode didn't show anything more than normal mode.

How can I further trace this issue down?


Related issues

Related to FreeNAS - Bug #63450: Bug #41676Closed

History

#1 Updated by Flole Systems about 1 year ago

To give some more Information: The last message I see is

Booting...
Start @ 0xffffffff8031e000 ...
EFI framebuffer Information:
addr, size       0xd0000000, 0x3ff0000
dimensions       800x600
stride           800
masks 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000

I am running (or trying to run ;) ) it on a HP Compaq 8200 Elite which has an Intel I3 Processor.

#2 Updated by Dru Lavigne about 1 year ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Reboot back into U4, create a debug (System -> Advanced -> Save debug), and attach it to this ticket.

#3 Updated by Dru Lavigne about 1 year ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Private changed from Yes to No

#4 Updated by Stefano T 9 months ago

Hi,

This bug is still here also with the final Release 11.2 stable.
All worked well until the bootloader was Grub. Now with the freeBSD bootloader, stuck on the same point of the original bug report.
HP compaq 8200 CMT with I7 and not I3. Latest Bios.

what can i try ?

TIA

#5 Updated by Dru Lavigne 9 months ago

Stefano: please try the steps in the Resolving Boot Issues section of https://www.ixsystems.com/blog/library/freenas-11-2-release/. If you make it to step 3, attach the new debug to this ticket and we'll take a look.

#6 Updated by Stefano T 9 months ago

Hi Dru,

reinstalled 11.1U6, restored the config, sent the debug report as per your request.
I wait for your answer

NB: i would to say that from 11.1U6 thru the 11.2RC2 doing the "in place" upgrade from the web interface, the system started well ... after the upgrade to the 11.2 STABLE the system does not boot anymore. Maybe that this info can help ...

thannk for your support

#7 Updated by Dru Lavigne 9 months ago

#8 Updated by Zit Seng Lai 8 months ago

Hi, I'm having the same problem with my system, I think it's perhaps to do with the motherboard. I have a Asus P8H67M Evo. The problem has been there since FreeNAS 11.2-Beta2, and verified still present in release FreeNAS 11.2-U1.

The bootup hangs with the final message:

Start @ 0xffffffff80322000 ...
EFI framebuffer information:
addr, size 0xe0000000, 0x3ff0000
dimensions 800 x 600
stride 800
masks 0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000

I'm booted via EFI. Any other information I can help with?

#9 Updated by Dru Lavigne 8 months ago

Please create a new ticket with a debug attached.

Also available in: Atom PDF