Project

General

Profile

Bug #41916

Fix traceback in new UI when creating new VM disk image

Added by Aaron St. John over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Seen in FreeNAS-11.2-MASTER-201808160915

Steps to reproduce:
1. Go to Virtual Machines
2. Go through the wizard until "Hard Disks" is reached.
3. Select "Create new disk image". In the "Select a pool or dataset" file picker, pick a pool on the system.
4. Click next on "Network Interface".
5. At "Installation Media" upload an ISO from the local system. Choose the ISO save location.
6. Click "Next".
7. Click "Submit". Observer error (see screenshot).

I found on the "Hard Disks" step that if the user manually types the name of the pool WITHOUT the /mnt the wizard creates pool/dataset for the VM as normal. In turn, the VM is successfully created.
It's as if the file picker field is passing in the /mnt to the name. Thus, throwing the error that the pool/dataset doesn't exist.

VM_creation_bug.png (175 KB) VM_creation_bug.png Aaron St. John, 08/16/2018 10:36 AM
24546

Related issues

Is duplicate of FreeNAS - Bug #41592: Use drop-down menu for Adding a VM Disk Device in new UIDone

History

#1 Updated by Aaron St. John over 1 year ago

Here is an example to make it more clear.

When creating a VM, I have a pool on the system called "Apples". On step 4 of the wizard I choose "Create new disk image" and choose a pool using the file picker (/mnt/Apples). I receive the error.

However, if I were to manually type "Apples" without the /mnt in the file path, the VM will create as desired.

#2 Updated by Dru Lavigne over 1 year ago

  • Is duplicate of Bug #41592: Use drop-down menu for Adding a VM Disk Device in new UI added

#3 Updated by Dru Lavigne over 1 year ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

Aaron: the fix in the duplicate ticket was just merged so should be in the next nightly. Please reopen if this is still reproducible once the fix is in a build.

#4 Updated by Vaibhav Chauhan over 1 year ago

  • Status changed from Closed to In Progress
  • Assignee changed from Erin Clark to Vaibhav Chauhan

#5 Updated by Dru Lavigne over 1 year ago

  • Target version changed from N/A to 11.2-BETA3
  • Reason for Closing deleted (Duplicate Issue)

#6 Updated by Erin Clark over 1 year ago

  • Status changed from In Progress to Ready for Testing

#7 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Creating new disk image for VM results in an error. to Fix traceback in new UI when creating new VM disk image
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#8 Updated by Aaron St. John over 1 year ago

  • Status changed from Ready for Testing to Passed Testing
  • Needs QA changed from Yes to No

Tested on FreeNAS-11.2-MASTER-201808170900

Test case:
1. Go to Virtual Machines
2. Go through the wizard for creating a VM.
3. On the step for "Hard Disks" select "Create new disk image" and use the file browser to select a pool.
4. Finish the wizard and observe that there is no more error due to the /mnt being in the pool name.

#9 Updated by Dru Lavigne over 1 year ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF