Project

General

Profile

Bug #42048

Fix bug in rsync plugin which made the validation for rsync fail

Added by Aaron Reed over 1 year ago. Updated over 1 year ago.

Status:
Done
Priority:
No priority
Assignee:
Waqar Ahmed
Category:
Middleware
Target version:
Seen in:
Severity:
Med High
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

All my rsync tasks were working fine before my upgrade to FreeNAS-11.2-BETA2
Now I'm receiving [Errno 2] No such file or directory: '/.ssh/known_hosts'
I've checked all my ssh keys and can login ssh passwordless fine.

Associated revisions

Revision f95b1022 (diff)
Added by Waqar Ahmed over 1 year ago

Rsync bug fix This commit fixes a bug in rsync plugin which made the validation for rsync fail. The issue stemmed from a probable asyncssh version upgrade which started checking for known hosts file via an environment variable which wasn't set when middlewared was running in daemon mode. Ticket: #42048

Revision 87f7e9fd (diff)
Added by Waqar Ahmed over 1 year ago

Rsync bug fix This commit fixes a bug in rsync plugin which made the validation for rsync fail. The issue stemmed from a probable asyncssh version upgrade which started checking for known hosts file via an environment variable which wasn't set when middlewared was running in daemon mode. Ticket: #42048

History

#1 Updated by Aaron Reed over 1 year ago

  • File debug-freenas-20180817170822.txz added
  • Private changed from No to Yes

#2 Updated by Dru Lavigne over 1 year ago

  • Category changed from Services to OS
  • Assignee changed from Release Council to Alexander Motin

#3 Updated by Alexander Motin over 1 year ago

  • Assignee changed from Alexander Motin to William Grzybowski

Isn't it something from middleware side? The global path '/.ssh/known_hosts' looks suspicious to me, just not sure where it comes from.

#4 Updated by William Grzybowski over 1 year ago

  • Category changed from OS to Middleware
  • Assignee changed from William Grzybowski to Waqar Ahmed
  • Severity changed from New to Med High

Waqar can you try to reproduce this? Seems like another regression on rsync tasks?

#5 Updated by Waqar Ahmed over 1 year ago

  • Status changed from Unscreened to In Progress

#6 Updated by Dru Lavigne over 1 year ago

  • File deleted (debug-freenas-20180817170822.txz)

#7 Updated by Dru Lavigne over 1 year ago

  • Target version changed from Backlog to 11.2-BETA3
  • Private changed from Yes to No

#8 Updated by Bug Clerk over 1 year ago

  • Status changed from In Progress to Ready for Testing

#9 Updated by Dru Lavigne over 1 year ago

  • Subject changed from Rsync not working after upgrade to Fix bug in rsync plugin which made the validation for rsync fail
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#10 Updated by Aaron Reed over 1 year ago

  • Assignee changed from Waqar Ahmed to Dru Lavigne

After installing this updated file I can confirm the issue is resolved. My rsync tasks are now running again. Thank you guys for the fast response!

#11 Updated by Dru Lavigne over 1 year ago

  • Assignee changed from Dru Lavigne to Waqar Ahmed

#12 Updated by Dru Lavigne over 1 year ago

  • Status changed from Ready for Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF