Project

General

Profile

Bug #42269

Can't select tap interface to a VM (using classic UI)

Added by Benjamin Martinez about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No
Tags:

Description

Hello,

I just found this problem in freenas FreeNAS-11.1-U5.

When bridging a VM interface to a host interface you can only select phisical interfaces and tap interfaces added from the VLANs section.

But if you have a tap interface to use for internal use between VM they don't show on the list, although they apperar in the UI (network section) and on CLI.

How to reproduce it:

- From Network > Interfaces create a new interface.
Check that it shows on the UI and from CLI.
- IN VMs create a new VM and add a NIC device. Check that in the list "NIC to attach:" the new interface created isn't there.

As a side note I expected this to be solved with https://redmine.ixsystems.com/issues/27122 but it seems this one one be solved in a while. At least I expect the one I describe here to be solved before.


Related issues

Related to FreeNAS - Bug #27122: Add overhauled bridge support to APIDone

History

#1 Updated by Dru Lavigne about 1 year ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Benjamin: is this reproducible on U6? If so, please attach a debug (System -> Advanced -> Save debug) after reproducing on the U6 system.

#2 Updated by Benjamin Martinez about 1 year ago

  • File debug-lavochkin-20180826204926.tgz added

Just updated, and same behaviour.

But there is a problem in my description. Before adding an interface using the GUI you must create the tap interface using tunables. In my case several interfaces are created and added to the GUI.

Still I can't see why the VM GUI treats differently a physical interface and a tap.

I add the debug file and I'm all yours to test all you want.

#3 Updated by Dru Lavigne about 1 year ago

  • Category changed from GUI (new) to Middleware
  • Assignee changed from Release Council to William Grzybowski
  • Reason for Blocked deleted (Need additional information from Author)

#5 Updated by William Grzybowski about 1 year ago

  • Status changed from Unscreened to Closed
  • Reason for Closing set to Duplicate Issue

I understand the frustration but there is no reliable way to do this without proper bridge interfaces configuration and interfaces API redesign.

The related ticket is already being worked but, although it may be a while until it reaches a stable release.

#6 Updated by Dru Lavigne about 1 year ago

  • Related to Bug #27122: Add overhauled bridge support to API added

#7 Updated by Dru Lavigne about 1 year ago

  • File deleted (debug-lavochkin-20180826204926.tgz)

#8 Updated by Dru Lavigne about 1 year ago

  • Target version changed from Backlog to N/A
  • Private changed from Yes to No

#9 Updated by Benjamin Martinez about 1 year ago

I knew about bug https://redmine.ixsystems.com/issues/27122 y would even add that it should be combined with https://redmine.ixsystems.com/issues/27120 is the only way to do network segmentation in a sensible way. And they don't seem to be solved within the next months.

I just had faith that a simpler workaround might be done sooner.

Can't know if people think same as me. But if you hear that freenas supports containers and virtual machines you would expect a better network management.

That said I respect totally the decision of the developers and they must focus on the main goal of the software. My intention is to raise concern that at least is important for a couple of users.

Also available in: Atom PDF