Project

General

Profile

Bug #42299

Rm file will cause freenas crash restart

Added by gamexg gamexg about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Alexander Motin
Category:
OS
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Root@freenas:/mnt/pool1/ghomepcbak # date
Mon Aug 20 21:54:43 CST 2018
Root@freenas:/mnt/pool1/ghomepcbak # rm -rf *

Socket error Event: 32 Error: 10053.
Connection closing...Socket close.

Connection closed by foreign host.

Disconnected from remote host(FreeNas@gen8) at 21:56:11.

Type `help' to learn how to use Xshell prompt.

Will cause freenas to die and need to be restarted. Retrying three times in a row will trigger this issue each time.
After the problem occurs, ssh, http can not be connected, the display still displays the console settings and other content, no error message, the local keyboard click does not have any corresponding. Waiting for a while will display the attachment information, which should be followed by an automatic restart.

I will execute the zpool scrub to check if there is an error in the pool, but it shouldn't be a problem, because it was just executed a few days ago and no errors were checked.

Do you still need to provide additional content?
I will try to delete ghomepcbakdataset directly after I don't need to provide other content.

console.PNG (25.9 KB) console.PNG gamexg gamexg, 08/20/2018 07:10 AM
24863

Related issues

Related to FreeNAS - Bug #41910: Fix system crash/freeze when deleting many filesDone

History

#1 Updated by gamexg gamexg about 2 years ago

  • File debug-freenas-20180820140953.txz added
  • Private changed from No to Yes

#2 Updated by gamexg gamexg about 2 years ago

24863

#3 Updated by gamexg gamexg about 2 years ago

See #40928, I am also over 80% of the capacity here, trying to free up space by attempting to clear backups that are no longer needed.

I don't know if I should keep the current fault environment to provide more information about the crash or to free up space and try to reproduce the crash?

#4 Updated by gamexg gamexg about 2 years ago

Verify install did not report a problem.
Scrub of pool 'freenas-boot' finished . No problems were reported.
Pool1 and pool2 scrub are not yet complete.

#5 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Alexander Motin

#7 Updated by Alexander Motin about 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

It is a full duplicate of bug #41910. I am investigating it already. The system seem to be too "busy" to respond. Out of 4 CPU cores one looks like working on deletion (though I am not completely sure why it doesn't finish), while all the rest are spinning waiting for that, making system not responsive until watchdog timer fire.

You may try deleting one file at a time. I suppose it should work until better fix is available.

#8 Updated by Alexander Motin about 2 years ago

  • Related to Bug #41910: Fix system crash/freeze when deleting many files added

#9 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug-freenas-20180820140953.txz)

#10 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

#11 Updated by gamexg gamexg about 2 years ago

The ghomepcbak dataset was destroyed directly, and no problems occurred.

Also available in: Atom PDF