Project

General

Profile

Bug #43393

winbindd - deamon stops, unable to connect via smb after update to 11.1-U6

Added by Damien Myracle about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Andrew Walker
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Behaves as Intended
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

FreeNAS upgrade was executed.
Version before upgrade: 11.1-U5
Version after upgrade: 11.1-U6

Upgrade was done via gui using:
" Current Train: FreeNAS-11-STABLE (...) "
" Update Server: http://update.ixsystems.com/FreeNAS "

There was no issues before upgrade, after upgrade, samba server no longer works.

Connection attempt was made from host running GNU/Linux Debian Stretch Desktop (Gnome). Host used to connect to smb share's on FreeNAS 11.1-U5 with out any issues.

Relevant log message on the host attempting to connect:
gvfsd1154: dbus_mount_reply: Error from org.gtk.vfs.Mountable.mount(): Failed to retrieve share list from server: Connection timed out

This is from the log on FreeNAS server after upgrading to version 11.1-U6:

Aug 28 19:32:17 nas01 kernel: Failed to fully fault in a core file segment at VA 0x80180e000 with size 0xd000 to be written at offset 0x39b000 for process winbindd
Aug 28 19:32:17 nas01 kernel: Failed to fully fault in a core file segment at VA 0x80180e000 with size 0xd000 to be written at offset 0x39b000 for process winbindd
Aug 28 19:32:17 nas01 kernel: pid 19412 (winbindd), uid 0: exited on signal 6 (core dumped)

Please let me know if any other information needed to diagnose this issue.

Thank you for your help and development of FreeNAS.

Damien

PS: when filing this request, there was no option in drop down menu for the FreeNAS v. 11.1-U6

History

#1 Updated by Damien Myracle about 2 years ago

  • Seen in changed from N/A to 11.1-U6

#2 Updated by Damien Myracle about 2 years ago

  • Subject changed from smb samba server crash to winbindd - deamon stops, unable to connect via smb after update to 11.1-U6

#3 Updated by Andrew Walker about 2 years ago

Hi Damien,
Can you please upload the winbindd.core file from /var/db/system/cores/ ?
Also generate a debug and attach to the ticket "System"-> "Advanced" -> "Save debug"

Once you have done this, try the following procedure from an ssh session:

service samba_server stop
rm /var/db/samba4/winbindd_cache*
net cache flush
service samba_server start

#4 Updated by Dru Lavigne about 2 years ago

  • Assignee changed from Release Council to Andrew Walker
  • Reason for Blocked set to Need additional information from Author

#5 Updated by Zack Hartmann about 2 years ago

I have also experienced an issue with SMB after performing this upgrade. Many hosts were unaffected, but two computers running Linux Mint both became unable to connect to FreeNAS box at the same time.

smbclient -L <freenas>
protocol negotiation failed: NT_STATUS_INVALID_NETWORK_RESPONSE

#6 Updated by Andrew Walker about 2 years ago

Zack Hartmann wrote:

I have also experienced an issue with SMB after performing this upgrade. Many hosts were unaffected, but two computers running Linux Mint both became unable to connect to FreeNAS box at the same time.

[...]

Please try lowering server minimum protocol in FreeNAS to NT1 per instructions here: https://www.ixsystems.com/blog/library/freenas-11-1-u6/

#7 Updated by Zack Hartmann about 2 years ago

Andrew Walker wrote:

Zack Hartmann wrote:

I have also experienced an issue with SMB after performing this upgrade. Many hosts were unaffected, but two computers running Linux Mint both became unable to connect to FreeNAS box at the same time.

[...]

Please try lowering server minimum protocol in FreeNAS to NT1 per instructions here: https://www.ixsystems.com/blog/library/freenas-11-1-u6/

This didn't fix it. I also performed the cache flush as described above.

$>sysctl freenas.services.smb.config.server_min_protocol=NT1    
freenas.services.smb.config.server_min_protocol: SMB2 -> NT1                    
$>service samba_server restart   

#8 Updated by Andrew Walker about 2 years ago

Try the following:

service ix-pre-samba start

service samba_server restart

ix-pre-samba is required because it will regenerate your smb4.conf file.

#9 Updated by Zack Hartmann about 2 years ago

Andrew Walker wrote:

Try the following:
[...]
[...]

ix-pre-samba is required because it will regenerate your smb4.conf file.

No effect. Same stubborn error.

#10 Updated by Andrew Walker about 2 years ago

Zack Hartmann wrote:

Andrew Walker wrote:

Try the following:
[...]
[...]

ix-pre-samba is required because it will regenerate your smb4.conf file.

No effect. Same stubborn error.

Please create a fresh redmine ticket for your problem and attach a debug. It is not clear that this is the same issue that the initial user reported.

#11 Updated by Damien Myracle about 2 years ago

Andrew Walker wrote:

Hi Damien,
Can you please upload the winbindd.core file from /var/db/system/cores/ ?
Also generate a debug and attach to the ticket "System"-> "Advanced" -> "Save debug"

Once you have done this, try the following procedure from an ssh session:
[...]

Hello Andrew, could you please give me a bit more time to collect data you have requested.
The host in question carries services I can not bring off line immediately.
To bring lost functionality as soon as possible, I had to roll back the boot environment back to the previous version - 11.1-U5.

The roll back process also did not go smoothly. I think I should open another bug report so you guys are aware of the experience in the field.

Once the 11.1-U5 environment was loaded, all services (nfs for the vm host and the file sharing via smb) was up an operational with out any issues.

I can attempt to bring the services off line tonight and run the upgrade again to see if the issue still persist and collect data you need for diagnostics.

Thank you for your response and assistance. iXsystems are awesome! :)

D. Myracle

#12 Updated by Damien Myracle about 2 years ago

  • File debug-nas01-20180831014750.tgz added
  • File winbindd.core added

Andrew Walker wrote:

Hi Damien,
Can you please upload the winbindd.core file from /var/db/system/cores/ ?
Also generate a debug and attach to the ticket "System"-> "Advanced" -> "Save debug"

Once you have done this, try the following procedure from an ssh session:
[...]

Hello Andrew, reporting the results of the steps you have suggested to take to mitigate this issue...

Upgrade was initiated once more.
Using GUI, upgrade was performed, from version 11.1-U5 to version 11.1-U6
Confirmed that smb/winbindd are not functioning as expected, requests from the client(s) to the host are timing out.

File '/var/db/system/cores/winbindd.core' was copied over ssh and uploaded/attached to this ticket.
File 'debug-nas01-20180831014750.tgz' was downloaded via gui and also attached to this ticket.

Please confirm that all and any uniquely identifiable information contained in those files will remain private and used only for diagnostics.

Once these files where downloaded, per your instructions, samba service was stopped, winbind_cache* files where removed from /var/db/samba4/ directory, net cache was flushed and samba server was restarted.

Unfortunately this did not resolved the issue and file sharing via smb is still not functioning.

In order to continue operations, FreeNAS ver. 11.1-U6 was rolled back to 11.1-U5.
Once roll-back was completed, all functionality, including smb file sharing, was confirmed to be running as expected.

Please let me know if the information provided is what you where looking for and if there is anything else I can do to help to diagnose this issue.

Thank you for your time and support.

D. Myracle

#13 Updated by Damien Myracle about 2 years ago

  • Private changed from No to Yes

#15 Updated by Andrew Walker about 2 years ago

  • File deleted (debug-nas01-20180831014750.tgz)

#16 Updated by Andrew Walker about 2 years ago

  • File deleted (winbindd.core)

#17 Updated by Andrew Walker about 2 years ago

  • Private changed from Yes to No

#19 Updated by Andrew Walker about 2 years ago

It looks like the server minimum protocol was not dropped to NT1 properly:

freenas.services.smb.config.server_max_protocol: SMB3
freenas.services.smb.config.server_min_protocol: SMB2

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter

server min protocol = NT1
ad restart the samba service.

#20 Updated by Damien Myracle about 2 years ago

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, thank you for your response.
When it was identified that samba services where not running as expected, I have explicitly adjusted settings under:
Main Menu-> Services -> SMB (Wrench/settings) NTLMv1 auth: Box checked.

Now, regarding the smb parameters adjustments you are recommending, I would love to follow your guidance, but there is a problem. Unfortunately there is another bug I am now experiencing. It has to do with the roll-back the software procedure.
Currently host is back to FreeNAS ver 11.1-U5 and I would have to upgrade it again to 11.1-U6 to test the solution you have proposed, but because of the issue with roll-back boot environment issue, I am very hesitant to go ahead and execute.

The ticket regarding issue with update/roll-back functionality was opened, issue was addressed, ticket is now closed, but the way it was addressed dose not really help a user like me in a filed to effectively move forward and implemented it.

Ticket recorded as: 43921
URL: https://redmine.ixsystems.com/issues/43921#change-294864

I am standing by to see if the developer handling that ticket might respond with comments on my last update, but ticket already is closed, and i can not move with testing until I can figure out how to handle issues with upgrade and roll-back procedure.

If you are able to comment on that issue and advise me what can be done, I would greatly appreciate it.

Thank you for your help and your time.
D. Myracle

#21 Updated by Andrew Walker about 2 years ago

NTLMv1 (authentication method) and NT1/SMB1 (SMB protocol version) are different settings. You can migrate to a new boot medium (SSD or larger USB) then perform the OS upgrade during your next maintenance window and update this ticket with your testing results.

#22 Updated by Andrew Walker about 2 years ago

  • Status changed from Unscreened to Blocked

#23 Updated by Damien Myracle about 2 years ago

Andrew Walker wrote:

NTLMv1 (authentication method) and NT1/SMB1 (SMB protocol version) are different settings. You can migrate to a new boot medium (SSD or larger USB) then perform the OS upgrade during your next maintenance window and update this ticket with your testing results.

Hello Andrew, unfortunately the original issue this ticket was created for still persist.
Here's what has been done.

SSD boot device was added to the server. SSD connected via SATA interface.
Latest FreeNAS 11.1-U6 image was downloaded from the www.freenas.org
Image was written (DD) to the USB disk. OS was installed to the SSD.
OS installed without any immediately obvious issues.
Network was configure via a local console on the host.
FreeNAS GUI was accessed, and config file (.tar) was loaded to the new OS.
Config used to restore configuration, was previously copied from the FreeNAS 11.1-U5 running on the same host.
OS rebooted, configuration was restored. Everything looked correctly, except...
SMB service are down, network clients are unable to connect tho shared resources via SMB.

This appears to be exact same issue I have experienced attempting to run an upgrade via GUI from 11.1-U5 to 11.1-U6

Following recommendations on this ticket and ticket #43921, new boot device was installed, new OS (FreeNAS 11.1-U6) was installed, configuration was uploaded to a new OS, reboot, and SMB is still not working out of the box.

Next I will attempt to manually add configuration for SMB services as discussed previously, but this is a current state of affairs :(

D. Myracle

#24 Updated by Damien Myracle about 2 years ago

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

#25 Updated by Zack Hartmann about 2 years ago

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, thank you for your response.
When it was identified that samba services where not running as expected, I have explicitly adjusted settings under:
Main Menu-> Services -> SMB (Wrench/settings) NTLMv1 auth: Box checked.

Now, regarding the smb parameters adjustments you are recommending, I would love to follow your guidance, but there is a problem. Unfortunately there is another bug I am now experiencing. It has to do with the roll-back the software procedure.
Currently host is back to FreeNAS ver 11.1-U5 and I would have to upgrade it again to 11.1-U6 to test the solution you have proposed, but because of the issue with roll-back boot environment issue, I am very hesitant to go ahead and execute.

The ticket regarding issue with update/roll-back functionality was opened, issue was addressed, ticket is now closed, but the way it was addressed dose not really help a user like me in a filed to effectively move forward and implemented it.

Ticket recorded as: 43921
URL: https://redmine.ixsystems.com/issues/43921#change-294864

I am standing by to see if the developer handling that ticket might respond with comments on my last update, but ticket already is closed, and i can not move with testing until I can figure out how to handle issues with upgrade and roll-back procedure.

If you are able to comment on that issue and advise me what can be done, I would greatly appreciate it.

Thank you for your help and your time.
D. Myracle

The "Navigate to <Services>-><SMB> and add the auxiliary parameter" also worked for me - i'm very relieved!

#27 Updated by Andrew Walker about 2 years ago

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

Damien, can you please provide details on how you were mounting the SMB share on debian 9? Is it through gvfs or mount.cifs? If you're manually using mount.cifs, can you please provide the full mount command that you're using.

#28 Updated by Damien Myracle about 2 years ago

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

Damien, can you please provide details on how you were mounting the SMB share on debian 9? Is it through gvfs or mount.cifs? If you're manually using mount.cifs, can you please provide the full mount command that you're using.

Hello Andrew,
You would think this is a such a simple question... and oh no... dear lord! It took some digging around to find an answer to your question.
Let me try to answer it...
On Debian Stretch (9) with Gnome Desktop, default file manager is Nautilus.
When a user connects to a remote samba server using Nautilus, smb share ends up been mounted in a ... some way, I do not understand (due to my ignorance), but, once you are 'connected' to the remote share, the only way I can locate where and how this connection is made is by listing following:

First, navigate to:
$ cd /run/user/1000/gvfs

and if you do:
/run/user/1000/gvfs$ ls

you will get:
smb-share:server=(ip-redacted),share=(share-redacted),user=(user-reducted)

The <*-redacted> listed as my freenas hosts ip address, share name, and the user name I provided when connection to smb share was established using Nautilus File manager.

I hope this answers your question. If not, please let me know and I will attempt to dig deeper in to inner-workings of ... debian/gnome/nautilus way of 'mounting' a share via smb.

Thank you for your time and your support.

Damien Myracle

#29 Updated by Dru Lavigne about 2 years ago

  • Status changed from Blocked to Unscreened
  • Reason for Blocked deleted (Need additional information from Author)

#30 Updated by Damien Myracle almost 2 years ago

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

Damien, can you please provide details on how you were mounting the SMB share on debian 9? Is it through gvfs or mount.cifs? If you're manually using mount.cifs, can you please provide the full mount command that you're using.

Hello guys, is there an update on this ticket?

Thank you.

#31 Updated by Andrew Walker almost 2 years ago

Damien Myracle wrote:

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

Damien, can you please provide details on how you were mounting the SMB share on debian 9? Is it through gvfs or mount.cifs? If you're manually using mount.cifs, can you please provide the full mount command that you're using.

Hello guys, is there an update on this ticket?

Thank you.

Damien, I apologize, you had previously responded

"This issue appears to be all bout min smb protocol used to negotiate between client and the host. Would you say this likely related to client not configured to use a newer version of SMB... NT2?"

Nautilus in Debian currently uses SMB1. We're preparing to add a checkbox to enable SMB1 support in the UI. Are you experiencing problems with the minimum protocol at NT1? If so, can you attach a new debug?

#32 Updated by Damien Myracle almost 2 years ago

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

Damien, can you please provide details on how you were mounting the SMB share on debian 9? Is it through gvfs or mount.cifs? If you're manually using mount.cifs, can you please provide the full mount command that you're using.

Hello guys, is there an update on this ticket?

Thank you.

Damien, I apologize, you had previously responded

"This issue appears to be all bout min smb protocol used to negotiate between client and the host. Would you say this likely related to client not configured to use a newer version of SMB... NT2?"

Nautilus in Debian currently uses SMB1. We're preparing to add a checkbox to enable SMB1 support in the UI. Are you experiencing problems with the minimum protocol at NT1? If so, can you attach a new debug?

Hello Mr. Walker.
In short, once the 'Axillary parameters' field under 'Services -> SMB' has been configured with 'server min protocol = NT1' string was set, Debian Stretch / Nautilus clients connect to SMB shares without problems.

I can confirm that it is in fact issue of the client side, specifically Nautilus file manager used in Debian Stretch not able to establish connection to server side using later / more modern revision(s) of SMB protocol.

If you are considering adding the check box to instruct SMB service of FreeNAS/TrueNAS to use NT1 smb protocol, that would be absolutely AWESOME! That way users community of Debian OS would be able to continue working with FreeNAS/TrueNAS via SMB.

Thank you for that consideration.

Could I ask if someone from the FreeNAS dev team considered to reach out to Debain / Nautilus dev team to make them aware of this issue?
If yes, could you share info if there is an opened ticket and what it is, so I can add more info to it.
If not, I will reach out to Debian project and open ticket with them myself.

Thank you for your time and work that you do. You guys are awesome!

D. Myracle

#33 Updated by Damien Myracle almost 2 years ago

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

Damien, can you please provide details on how you were mounting the SMB share on debian 9? Is it through gvfs or mount.cifs? If you're manually using mount.cifs, can you please provide the full mount command that you're using.

Hello guys, is there an update on this ticket?

Thank you.

Damien, I apologize, you had previously responded

"This issue appears to be all bout min smb protocol used to negotiate between client and the host. Would you say this likely related to client not configured to use a newer version of SMB... NT2?"

Nautilus in Debian currently uses SMB1. We're preparing to add a checkbox to enable SMB1 support in the UI. Are you experiencing problems with the minimum protocol at NT1? If so, can you attach a new debug?

On a side note... OS was upgraded from 11.1U6 stable train to 11.2-release stable train about 8 hours ago, and the axillary parameters for the SMB service did migrated to the new 11.2-release version on the system properly, and SMB functionality remained in place.
However, this is a purely UI related comment - in a new GUI of 11.2-relase version, it is extremely hard to read the line - 'Axillary parameters' where the additional instructions must be written.
I missed that line couple of times looking at the options for SMB service.
In general, most elements of the UI so large, they don't fit in to the browser window so zoom function of the browser has to be used to zoom out to 80% (FirefoxESR) and 90% (Chromium). At the same time, under SMB service properties opposite has to be done to zoom in to a ~ 120% to be able to read the text "Axillary parameters" line.
I thought I would give you this feed back, maybe you can comment internally to relevant UI dev team members.

Once again, thank you for your work and your support.

D. Myracle

#34 Updated by Andrew Walker almost 2 years ago

  • Status changed from Unscreened to Closed
  • Needs QA changed from Yes to No
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

Damien Myracle wrote:

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

Damien Myracle wrote:

Andrew Walker wrote:

It looks like the server minimum protocol was not dropped to NT1 properly:
[...]

Let's try changing this a different way. Navigate to <Services>-><SMB> and add the auxiliary parameter [...] ad restart the samba service.

Hello Andrew, adding the instruction you have provided 'server min protocol = NT1' and restarting samba services in fact restored connectivity from the network clients to the host via SMB.

Thank you for your advise.

Could you please let me know if this is a bug or this is expected behavior going forward?
Would it be necessary to add this parameter to samba services in FreeNAS ver 11.2 to maintain accessibility of the Linux clients (Debian 9 Stretch) to the FreeNAS host via SMB?

This issue appears to be all bout min smb protocol used to negotiate between client and the host.
Would you say this likely related to client not configured to use a newer version of SMB... NT2?

Please let me know.
Thank you...

D. Myracle

Damien, can you please provide details on how you were mounting the SMB share on debian 9? Is it through gvfs or mount.cifs? If you're manually using mount.cifs, can you please provide the full mount command that you're using.

Hello guys, is there an update on this ticket?

Thank you.

Damien, I apologize, you had previously responded

"This issue appears to be all bout min smb protocol used to negotiate between client and the host. Would you say this likely related to client not configured to use a newer version of SMB... NT2?"

Nautilus in Debian currently uses SMB1. We're preparing to add a checkbox to enable SMB1 support in the UI. Are you experiencing problems with the minimum protocol at NT1? If so, can you attach a new debug?

On a side note... OS was upgraded from 11.1U6 stable train to 11.2-release stable train about 8 hours ago, and the axillary parameters for the SMB service did migrated to the new 11.2-release version on the system properly, and SMB functionality remained in place.
However, this is a purely UI related comment - in a new GUI of 11.2-relase version, it is extremely hard to read the line - 'Axillary parameters' where the additional instructions must be written.
I missed that line couple of times looking at the options for SMB service.
In general, most elements of the UI so large, they don't fit in to the browser window so zoom function of the browser has to be used to zoom out to 80% (FirefoxESR) and 90% (Chromium). At the same time, under SMB service properties opposite has to be done to zoom in to a ~ 120% to be able to read the text "Axillary parameters" line.
I thought I would give you this feed back, maybe you can comment internally to relevant UI dev team members.

Once again, thank you for your work and your support.

D. Myracle

The checkbox is coming soon. I believe the relevant devs on the Linux-side are aware of the limitations of cifs_utils at present. These issues will be ironed out as linux SMB clients update. We're all in the process of moving away from SMB1 for a variety of reasons. Ultimately, there's always going to be a certain amount of pain in deprecating these things.

#35 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from Backlog to N/A
  • Reason for Closing set to Behaves as Intended

Also available in: Atom PDF