Project

General

Profile

Bug #43745

Apply handleWSError to the websocket of the Jails section in new UI

Added by Michael Reynolds almost 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Lola Yang
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Update the handleWSError fixes for the Jails section.
This is the Jails version of 35395

JailWithSameName-2018-08-30.png (7 KB) JailWithSameName-2018-08-30.png Michael Reynolds, 08/30/2018 07:19 AM
Edit-JailWithSameName-2018-08-30.png (9.54 KB) Edit-JailWithSameName-2018-08-30.png Michael Reynolds, 08/30/2018 07:19 AM
Jail Error Advanced.png (62.2 KB) Jail Error Advanced.png Jeff Ervin, 09/21/2018 12:32 PM
27344
27355
31234

Related issues

Related to FreeNAS - Bug #35395: Apply handleWSError to the websocket of the storage section in new UIDone

History

#1 Updated by Dru Lavigne almost 2 years ago

  • Target version changed from Backlog to 11.2-RC1

#2 Updated by Dru Lavigne almost 2 years ago

  • Related to Bug #35395: Apply handleWSError to the websocket of the storage section in new UI added

#3 Updated by Michael Reynolds almost 2 years ago

27344
27355

Creating a jail with the same name as an existing jail gives an EINVAL popup
see: JailWithSameName-2018-08-30.png

Editing a jail via Jails -> Edit gives a different EINVAL popup
see: Edit-JailWithSameName-2018-08-30.png

#4 Updated by Erin Clark almost 2 years ago

  • Assignee changed from Erin Clark to Lola Yang

Jails should use handleWSError now but there may be things that need to be done to the page to allow for it to do things like apply errors to the appropriate fields. Passing to Lola for further consideration

#5 Updated by Lola Yang almost 2 years ago

This should be already fixed. it was caused by entity-job component, which can also handle the error get from middleware.

Michael, could you have a double check?

#6 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Unscreened to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Not Applicable

Michael: please leave a comment in this ticket if you can still reproduce on a latest nightly.

#7 Updated by Michael Reynolds almost 2 years ago

I still get the EINVAL error dialog as shown in JailWithSameName-2018-08-30.png using the FreeNAS-11.2-MASTER-201809060900 (Build Date: Sep 6, 2018 12:14) Nightly

#8 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Closed to Unscreened
  • Target version changed from N/A to 11.2-RC1
  • Reason for Closing deleted (Not Applicable)

#9 Updated by Lola Yang almost 2 years ago

  • Subject changed from Apply handleWSError to the websocket of the Jails section in new UI to Apply handleWSError to the websocket of the Jails section in new UI, show EINVAL errors in form

#10 Updated by Lola Yang almost 2 years ago

  • Status changed from Unscreened to Screened

#11 Updated by Lola Yang almost 2 years ago

  • Status changed from Screened to In Progress

Update jail advanced creation UI since only jail create call will return EINVAL error, jail edit doesn't.

https://github.com/freenas/webui/pull/1241

#12 Updated by Lola Yang almost 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#13 Updated by Dru Lavigne almost 2 years ago

  • Subject changed from Apply handleWSError to the websocket of the Jails section in new UI, show EINVAL errors in form to Apply handleWSError to the websocket of the Jails section in new UI

#14 Updated by Jeff Ervin almost 2 years ago

31234

Test Passed FreeNAS-11.2-MASTER-201809210904

#15 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF