Project

General

Profile

Bug #43833

Jail creation status popup stays stuck at 20%

Added by Timothy Moore II about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Brandon Schneider
Category:
Middleware
Target version:
Severity:
Low
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Testing the new UI with a FreeNAS system updated to FreeNAS-11.2-MASTER-201808300858:

Log in, go to Jails, and click the + . Choose a Release that has never been fetched, and fill in the rest of the fields. Popup appears when jail creation begins, but appears to get stuck at 20%.


Related issues

Related to FreeNAS - Bug #43328: Have jail wizard wait until SUCCESS before leaving pageDone
Related to FreeNAS - Bug #45552: Improve/provide more info for the Jail Creation progress bar in new uiClosed
Is duplicate of FreeNAS - Feature #36943: Add progress for iocage jail creation and fetching to middlewareDone

History

#1 Updated by Timothy Moore II about 2 years ago

  • Related to Bug #43328: Have jail wizard wait until SUCCESS before leaving page added

#2 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.2-RC1

#3 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to William Grzybowski

I noticed this too, and it does eventually move from 20% but not until it is almost done installing the jail. I noticed while it was at 20% the logs told me that the middleware was fetching things but it doesn't seem to move again until all the fetching is done, perhaps this percentage could move a little each time a portion of the download completes? Passing this to William as this is something that needs to be fixed on the middleware side.

#4 Updated by Erin Clark about 2 years ago

  • Category changed from GUI (new) to Middleware

#5 Updated by William Grzybowski about 2 years ago

  • Assignee changed from William Grzybowski to Brandon Schneider

#6 Updated by Brandon Schneider about 2 years ago

  • Status changed from Unscreened to Not Started

#7 Updated by Lola Yang about 2 years ago

  • Related to Bug #45552: Improve/provide more info for the Jail Creation progress bar in new ui added

#8 Updated by Brandon Schneider about 2 years ago

  • Status changed from Not Started to In Progress

#9 Updated by Brandon Schneider about 2 years ago

  • Status changed from In Progress to Done
  • Severity changed from New to Low
  • Needs Merging changed from Yes to No

This was fixed by https://github.com/freenas/freenas/commit/52c8280e893be9f67392f64adb8ed0558552dae1#diff-733632ed3837168816d4101e2fbafafa

You will see it stall at 50% as it fetches, the UI could mention that it will sit at that while fetching a RELEASE, but the amount of effort required for that change would be substantial. There are considerations the jail plugin requires that are different then the other areas of the middleware.

#10 Updated by Dru Lavigne about 2 years ago

  • Is duplicate of Feature #36943: Add progress for iocage jail creation and fetching to middleware added

#11 Updated by Dru Lavigne about 2 years ago

  • Status changed from Done to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Reason for Closing set to Duplicate Issue

Also available in: Atom PDF