Project

General

Profile

Bug #43910

Properly handle VM non-existing state in new UI

Added by Michael Reynolds about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Vaibhav Chauhan
Category:
GUI (new)
Target version:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

After modifying a Virtual Machine, using any of the Options menu items, or going to Options -> Edit,
all current virtual machines show "Loading..." under the VM name.

This causes further actions to look as if they aren't being done.

For example starting a VM. The "Loading..." changes to "starting" but never updates past that.
Making a change via options -> Edit looks to never complete.

Forcing a refresh with Control F5 or leaving the Virtual Machines section and returning makes everything go back to normal.

I can supply a video if need be.
See All-VMsInLoadingState-2018-08-30.png

All-VMsInLoadingState-2018-08-30.png (68.8 KB) All-VMsInLoadingState-2018-08-30.png Michael Reynolds, 08/30/2018 03:48 PM
Test VM4.png (203 KB) Test VM4.png Jeff Ervin, 09/24/2018 11:12 AM
Test VM3.png (313 KB) Test VM3.png Jeff Ervin, 09/24/2018 11:12 AM
Test VM2.png (220 KB) Test VM2.png Jeff Ervin, 09/24/2018 11:12 AM
Test VM1.png (271 KB) Test VM1.png Jeff Ervin, 09/24/2018 11:12 AM
27784
31476
31487
31498
31509

Related issues

Has duplicate FreeNAS - Bug #46025: VM stuck in loadingClosed

History

#1 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan
  • Needs Doc changed from Yes to No

#2 Updated by Dru Lavigne about 2 years ago

  • Target version changed from Backlog to 11.2-RC1

#3 Updated by Vaibhav Chauhan about 2 years ago

  • Status changed from Unscreened to In Progress

#4 Updated by Lola Yang about 2 years ago

  • Status changed from In Progress to Ready for Testing
  • Needs Merging changed from Yes to No

#5 Updated by Dru Lavigne about 2 years ago

  • Subject changed from All Virtual Machines go into a "Loading..." state after modifying a VM to Properly handle VM non-existing state in new UI

#6 Updated by Vaibhav Chauhan about 2 years ago

  • Has duplicate Bug #46025: VM stuck in loading added

#7 Updated by Jeff Ervin almost 2 years ago

31476
31487
31498
31509

FreeNAS-11.2-MASTER-201809240851

Modified testvm2, started, no issues with either VM created. Both run, both stop without getting stuck.

#8 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done

Also available in: Atom PDF