Project

General

Profile

Bug #44229

System alert 393 samba4.samba4alert failed handshake

Added by brandon chappell 11 months ago. Updated 9 months ago.

Status:
Closed
Priority:
No priority
Assignee:
William Grzybowski
Category:
Services
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Last few weeks have been having all sorts of issues, which began with update to 11.2 beta, which caused my 10gbe nics to stop working (https://forums.freenas.org/index.php?threads/nic-keeps-changing-from-up-to-down-and-cant-access-gui-freenas-11-2-beta.69381/), i then decided to go back to 11.1 and have been struggling to establish stability since. I ended up on 11.1U6 which seemed ok, but after installing my plugins (plex,transmission, syncthing) i keep getting this error being displayed, which results in jails timing out, Ui timing out, sluggish access times or not being able to access the nas at all, until i reboot. i created this debug last night while it was causing this error. but may have stumbled on something just tonight, that it is related to syncthing as when my server with syncthing which syncs with the nas' syncthing, was turned off, i didnt receive this error, but as soon as i started my server i got the error. ive now disabled it, reset the nas, and havent got it since (1hr or so).

freenas samba.png (105 KB) freenas samba.png brandon chappell, 09/02/2018 06:31 AM
28048

Related issues

Is duplicate of FreeNAS - Bug #46821: Disable loop debugDone

History

#1 Updated by Dru Lavigne 11 months ago

  • Category changed from Middleware to Services
  • Assignee changed from Release Council to John Hixson
  • Private changed from No to Yes
  • Seen in changed from 11.2-U3 to 11.1-U6

#2 Updated by Dru Lavigne 9 months ago

  • Assignee changed from John Hixson to William Grzybowski

#3 Updated by William Grzybowski 9 months ago

  • Status changed from Unscreened to Closed
  • Target version changed from Backlog to N/A
  • Reason for Closing set to Duplicate Issue

This is indeed related to syncthing, it opens thousands of file descriptors which causes some sort of lock contention in ZFS.

#4 Updated by William Grzybowski 9 months ago

  • Is duplicate of Bug #46821: Disable loop debug added

#6 Updated by Dru Lavigne 9 months ago

  • File deleted (debug-freenas-20180902080719.tgz)

#7 Updated by Dru Lavigne 9 months ago

  • Private changed from Yes to No

Also available in: Atom PDF