Project

General

Profile

Bug #44295

Cannot disable ldap service

Added by Simon Pierre Desrosiers about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
No priority
Assignee:
Simon Pierre Desrosiers
Category:
GUI (new)
Target version:
Seen in:
Severity:
New
Reason for Closing:
Duplicate Issue
Reason for Blocked:
Waiting for feedback
Needs QA:
Yes
Needs Doc:
Yes
Needs Merging:
Yes
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

Hello,

I cannot disable the ldap configuration on my freenas. It will give me the circle of wait for a few seconds then show me its disable, but if i click anywhere and then come back to ldap service, its stil enabled.

And since, I have a configuration that will not allow smb, it is a real problem as I cannot use smb anymore.


Related issues

Is duplicate of FreeNAS - Bug #43943: Add ability for user to disable LDAP config by setting an empty hostname in new UIDone

History

#1 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Simon: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Simon Pierre Desrosiers about 2 years ago

  • File fndebug.tar.gz added

Here you go.

Buy the way, it hangs for sooo long in the guy that it never downlods, I get kickout of the interface. I did via the terminal through ssh.

#3 Updated by Dru Lavigne about 2 years ago

  • Category changed from OS to GUI (new)
  • Assignee changed from Release Council to Erin Clark
  • Target version changed from Backlog to 11.2-RC1
  • Seen in changed from 11.2-RC2 to 11.2-BETA2

#4 Updated by Dru Lavigne about 2 years ago

  • Reason for Blocked deleted (Need additional information from Author)

#5 Updated by Erin Clark about 2 years ago

  • Assignee changed from Erin Clark to Vaibhav Chauhan

#6 Updated by Vaibhav Chauhan about 2 years ago

going thru your logs it seems like there is an error with network connectivity with LDAP server.

ERROR: {'desc': "Can't contact LDAP server", 'errno': 57, 'info': 'Socket is not connected'}
debug finished in 83 seconds for ldaptool get config_file

can you run

 ldaptool get config_file 
dropping into shell and show us the output ? it should look similar to if LDAP was once connected

root@freenas[~]# ldaptool get config_file
ldap_basedn=dc=ldap01,dc=tn,dc=xyz,dc=com
ldap_binddn=cn=admin,dc=ldap01,dc=tn,dc=xyz,dc=com
ldap_anonbind=0
ldap_hostname=ldap01.tn.xyz.com
ldap_host=ldap01.tn.xyz.com
ldap_port=389
ldap_usersuffix=
ldap_groupsuffix=
ldap_machinesuffix=
ldap_passwordsuffix=
ldap_sudosuffix=
ldap_krb_realm=
ldap_krb_kdc=
ldap_krb_admin_server=
ldap_krb_kpasswd_server=
ldap_keytab_principal=
ldap_keytab_file=
ldap_ssl=off
ldap_has_samba_schema=0
ldap_use_default_domain=0
ldap_certfile=
ldap_idmap_backend=ldap
ldap_timeout=10
ldap_dns_timeout=10

if you are seeing something like

ldaptool get config_file
ERROR: {'desc': "Can't contact LDAP server", 'errno': 57, 'info': 'Socket is not connected'}

I can say that you have some networking issues connecting to LDAP server.

#7 Updated by Vaibhav Chauhan about 2 years ago

  • Status changed from Unscreened to Blocked
  • Assignee changed from Vaibhav Chauhan to Simon Pierre Desrosiers
  • Reason for Blocked set to Need additional information from Author

#9 Updated by Simon Pierre Desrosiers about 2 years ago

I know that, the LDAP server is no longer available.

Here is the output of the command :

simonpie@sancy:~ % sudo ldaptool get config_file
Password:
Password:
ERROR: {'desc': "Can't contact LDAP server", 'errno': 57, 'info': 'Socket is not connected'}
simonpie@sancy:~ %

#10 Updated by Dru Lavigne about 2 years ago

  • Status changed from Blocked to Unscreened
  • Assignee changed from Simon Pierre Desrosiers to Vaibhav Chauhan
  • Reason for Blocked deleted (Need additional information from Author)

#11 Updated by Vaibhav Chauhan about 2 years ago

  • Status changed from Unscreened to Blocked
  • Assignee changed from Vaibhav Chauhan to Simon Pierre Desrosiers
  • Reason for Blocked set to Waiting for feedback

#12 Updated by Vaibhav Chauhan about 2 years ago

ok please correct me if I am wrong, you cannot disable LDAP directory service running on FreeNAS system when LDAP server is down ? if yes I have a fix for #43943 which should solve the issue for you.

if no please explain it clearly, Reproduction Case, Results and Desired results ?

#13 Updated by Dru Lavigne about 2 years ago

  • Is duplicate of Bug #43943: Add ability for user to disable LDAP config by setting an empty hostname in new UI added

#14 Updated by Dru Lavigne about 2 years ago

  • File deleted (fndebug.tar.gz)

#15 Updated by Dru Lavigne about 2 years ago

  • Status changed from Blocked to Closed
  • Target version changed from 11.2-RC1 to N/A
  • Private changed from Yes to No
  • Reason for Closing set to Duplicate Issue

Simon: I'll close out this bug as the fix will occur on the duplicate ticket.

#16 Updated by Simon Pierre Desrosiers about 2 years ago

29679
29690
29701
29705

Hello,

I think we agree. The ldap server is no longer available and I am trying to disable the existing configuration on the freenas. Configuration that was trying to connect to the nolonger existing ldap server.

Saddly, the old UI does not help. I have tried multiple configuration (enable/disable, hostname, base dn ...) without success, they all time out.

I shall try the beta-3 tonight.

#17 Updated by Simon Pierre Desrosiers about 2 years ago

Update to beta3 worked. In the new UI. SMB is back.

Also available in: Atom PDF