Project

General

Profile

Bug #44306

FIx issues with SMART config generation

Added by Stephen Makk about 2 years ago. Updated almost 2 years ago.

Status:
Done
Priority:
No priority
Assignee:
Vladimir Vinogradenko
Category:
Middleware
Target version:
Seen in:
Severity:
New
Reason for Closing:
Reason for Blocked:
Needs QA:
No
Needs Doc:
No
Needs Merging:
No
Needs Automation:
No
Support Suite Ticket:
n/a
Hardware Configuration:
ChangeLog Required:
No

Description

I have two identical servers. After trying to boot to an external USB stick, SMART fails to start automatically or manually. smartd.conf is not generated. ONly hard disks are set to have SMART enabled in GUI. Cannot save changes to SMART enable tick box.


Related issues

Has duplicate FreeNAS - Bug #45684: /usr/local/etc/rc.d/smartd-daemon: WARNING: /usr/local/etc/smartd.conf is not readable.Closed

Associated revisions

Revision badfe7e3 (diff)
Added by Vladimir Vinogradenko about 2 years ago

Fix SMART Test form parse in legacy UI Ticket: #44306

Revision 53cddac8 (diff)
Added by Vladimir Vinogradenko about 2 years ago

FIx a issues with SMART config generation: * Day of week should be expressed with one decimal digit * Month and day of week can be specified using their abbreviated names Ticket: #44306

Revision fa0e5da7 (diff)
Added by Vladimir Vinogradenko about 2 years ago

FIx issues with SMART config generation: * Day of week should be expressed with one decimal digit * Month and day of week can be specified using their abbreviated names Ticket: #44306

History

#1 Updated by Dru Lavigne about 2 years ago

  • Private changed from No to Yes
  • Reason for Blocked set to Need additional information from Author

Stephen: please reproduce then attach a debug (System -> Advanced -> Save debug) to this ticket.

#2 Updated by Stephen Makk about 2 years ago

  • File debug (1).tgz added

#3 Updated by Stephen Makk about 2 years ago

Now my second machine started doing it too. That one never had any USB stick jiggery-pokery today. I did upgrade my HP ILO3 monitoring firmware on both machines.

#4 Updated by Dru Lavigne about 2 years ago

  • Category changed from Services to Middleware
  • Assignee changed from Release Council to William Grzybowski

#5 Updated by William Grzybowski about 2 years ago

  • Assignee changed from William Grzybowski to Vladimir Vinogradenko
  • Target version changed from Backlog to 11.2-RC1
  • Reason for Blocked deleted (Need additional information from Author)

#6 Updated by Bug Clerk about 2 years ago

  • Status changed from Unscreened to In Progress

#7 Updated by Vladimir Vinogradenko about 2 years ago

Stephen, as temporary workaround please resave all your SMART tests using legacy UI. Please also note that due to bug all months and days of week would initially be unchecked.

#8 Updated by Dru Lavigne about 2 years ago

  • File deleted (debug (1).tgz)

#9 Updated by Dru Lavigne about 2 years ago

  • Private changed from Yes to No

#10 Updated by Stephen Makk about 2 years ago

  • File Smartd.zip added

Tried workaround., Did not work. Says smartd.conf is unreadable. Continues to be absent. I attach traceback.

#11 Updated by Bug Clerk about 2 years ago

  • Status changed from In Progress to Ready for Testing

#12 Updated by Dru Lavigne about 2 years ago

  • File deleted (Smartd.zip)

#13 Updated by Dru Lavigne about 2 years ago

  • Subject changed from SMART fails to start. smartd.conf disappeared to FIx issues with SMART config generation
  • Needs Doc changed from Yes to No
  • Needs Merging changed from Yes to No

#14 Updated by Dru Lavigne about 2 years ago

  • Has duplicate Bug #45684: /usr/local/etc/rc.d/smartd-daemon: WARNING: /usr/local/etc/smartd.conf is not readable. added

#15 Updated by Seth Hahn about 2 years ago

  • Seen in changed from 11.2-BETA2 to 11.2-BETA3

Same problem here. /etc/ix.rc.d/ix-smartd is missing as well.

#17 Updated by Bonnie Follweiler almost 2 years ago

  • Status changed from Ready for Testing to Passed Testing

Test Passed in FreeNAS-11.2-MASTER-201809270704

#18 Updated by Dru Lavigne almost 2 years ago

  • Status changed from Passed Testing to Done
  • Needs QA changed from Yes to No

Also available in: Atom PDF